POJ 1276 Cash Machine【多重揹包】

Cash Machine
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 35022   Accepted: 12706

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example, 

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. 

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. 

Notes: 
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. 

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format: 

cash N n1 D1 n2 D2 ... nN DN 

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. 

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. 

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0

Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash. 

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash. 

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

Source


原題鏈接:http://poj.org/problem?id=1276

題意:有各種不同面值的貨幣,每種面值的貨幣有不同的數量,請找出利用這些貨幣可以湊成的最接近且小於等於給定的數字cash的金額.

樣例1:

要取735,取款機內有3種錢:4張125的,6張5的,3張350的.

735=3*125+2*5+1*350

動態規劃,多重揹包,可以二進制優化.

AC代碼:

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
using namespace std;

struct node
{
    int n,v;
} a[20];

int dp[100010];

int main()
{
    int sum,n,i,j,k;
    //freopen("C:\\Documents and Settings\\Administrator\\桌面\\data.txt","r",stdin);
    while(~scanf("%d%d",&sum,&n))
    {
        for(i = 1; i<=n; i++)
            scanf("%d%d",&a[i].n,&a[i].v);
        if(!sum||!n)
        {
            printf("0\n");
            continue;
        }

        memset(dp,0,sizeof(dp));
        dp[0] = 1;
        int MAX = 0,tem;
        for(i = 1; i<=n; i++)
        {
            for(j = MAX; j>=0; j--)
            {
                if(dp[j])
                {
                    for(k = 1; k<=a[i].n; k++)
                    {
                        tem = j+k*a[i].v;
                        if(tem>sum)
                            continue;
                        dp[tem] = 1;
                        if(tem>MAX)
                            MAX = tem;
                    }
                }
            }
        }
        printf("%d\n",MAX);
    }

    return 0;
}
參考代碼:

二進制優化:http://www.cnblogs.com/zjbztianya/archive/2013/10/29/3394065.html
http://www.cnblogs.com/candy99/p/5796219.html
http://blog.csdn.net/zhou_yujia/article/details/51376157
http://blog.csdn.net/lyy289065406/article/details/6648102
http://www.cnblogs.com/372465774y/archive/2013/07/12/3187223.html
http://blog.csdn.net/zcmartin2014214283/article/details/51373299


發佈了374 篇原創文章 · 獲贊 211 · 訪問量 70萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章