2月3日 Visible Lattice Points(歐拉函數)

Description


A lattice point (x, y) in the first quadrant (x and y are integers greater than or equal to 0), other than the origin, is visible from the origin if the line from (0, 0) to (x, y) does not pass through any other lattice point. For example, the point (4, 2) is not visible since the line from the origin passes through (2, 1). The figure below shows the points (x, y) with 0 ≤ x, y ≤ 5 with lines from the origin to the visible points.




Write a program which, given a value for the size, N, computes the number of visible points (x, y) with 0 ≤ x, y ≤ N.


Input


The first line of input contains a single integer C (1 ≤ C ≤ 1000) which is the number of datasets that follow.


Each dataset consists of a single line of input containing a single integer N (1 ≤ N ≤ 1000), which is the size.


Output


For each dataset, there is to be one line of output consisting of: the dataset number starting at 1, a single space, the size, a single space and the number of visible points for that size.


Sample Input


4
2
4
5
231
Sample Output


1 2 5
2 4 13
3 5 21

4 231 32549


就是找不大於自身互質整數的個數(歐拉函數),把圖分成兩個三角,注意(1,1)這個點是共享的。

用素數篩的方法。

離線算可能更快一點(不需要多次memset重新算),但沒有試。

#include<cstdio>
#include<algorithm>
#define maxn 100005
int phi[maxn],pri[maxn],notpri[maxn];
void euler(int n)
{
	memset(phi, 0, sizeof(phi));
	memset(pri, 0, sizeof(pri));
	memset(notpri, 0, sizeof(notpri));
	phi[1] = 1;
	int cnt = 0;
	for (int i = 2; i <= n; i++)
	{
		if (!notpri[i])
		{
			pri[cnt++] = i;
			phi[i] = i - 1;
		}
		for (int j = 0; j < cnt; j++)
		{
			if (i*pri[j] > n)break;
			notpri[i*pri[j]] = 1;
			if (i%pri[j]==0)
			{
				phi[i*pri[j]] = phi[i]*pri[j];
				break;
			}
			phi[i*pri[j]] = phi[i] * (pri[j]-1);
		}
	}
}
int main()
{
	int t;
	scanf("%d", &t);
	for (int i = 0; i < t; i++)
	{
		int m,sum=0;
		scanf("%d", &m);
		euler(m);
		for (int j = 2; j <= m; j++)
		{
			sum += phi[j];
		}
		sum += 1;
		sum *= 2;
		sum += 1;
		printf("%d %d %d\n", i+1,m,sum);
	}
	return 0;
}


發佈了50 篇原創文章 · 獲贊 11 · 訪問量 3萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章