2月20日 Primitive Roots(原根)

原根和離散對數是密碼學和數論的重要概念,本題如下(poj 1284):

Description


We say that integer x, 0 < x < p, is a primitive root modulo odd prime p if and only if the set { (xi mod p) | 1 <= i <= p-1 } is equal to { 1, ..., p-1 }. For example, the consecutive powers of 3 modulo 7 are 3, 2, 6, 4, 5, 1, and thus 3 is a primitive root modulo 7. 
Write a program which given any odd prime 3 <= p < 65536 outputs the number of primitive roots modulo p. 
Input


Each line of the input contains an odd prime numbers p. Input is terminated by the end-of-file seperator.
Output


For each p, print a single number that gives the number of primitive roots in a single line.
Sample Input


23
31
79
Sample Output


10
8
24

原根個數爲phi(phi(n)),phi爲歐拉函數,關於羣、生成元的推導沒有細看(後面會看),本題實際上還是一個歐拉函數打表,根據輸入調出表中的值就行了。

#include<cstdio>
#define MAX 65537
int phi[MAX],notpri[MAX],pri[MAX];
void calphi()
{
	int cnt = 0;
	phi[1] = 1;
	for (int i = 2; i < MAX-1; i++)
	{
		if (!notpri[i])
		{
			phi[i] = i - 1;
			pri[cnt++] = i;
		}
		for (int j = 0; j < cnt; j++)
		{
			if (pri[j] * i > MAX)break;
			
				notpri[pri[j] * i] = 1;
				if (i%pri[j] == 0)
				{
					phi[i*pri[j]] = phi[i] * pri[j];
					break;
				}
				else
				{
					phi[i*pri[j]] = phi[i] * (pri[j] - 1);
				}		
		}
	}
}
int main()
{
	int n;
	calphi();
	while (scanf("%d", &n)!=EOF)
	{
		printf("%d\n", phi[phi[n]]);
	}
	return 0;
}


發佈了50 篇原創文章 · 獲贊 11 · 訪問量 3萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章