hdoj1097

A hard puzzle

 

 

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 35024    Accepted Submission(s): 12586

 

 

 

Problem Description

lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.

 

 

Input

There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)

 

 

Output

For each test case, you should output the a^b's last digit number.

 

 

Sample Input


 

7 66 8 800

 

 

Sample Output


 

9 6

 

<span style="font-size:18px;">#include <stdio.h>
int main()
{
    int a,b,i,sum;
    while(scanf("%d%d",&a,&b)!=EOF)
    {
        sum=1;
        a%=10; b%=4;
        if(b==0)
            b=4;
        for(i=1;i<=b;++i)
            sum*=a;
        printf("%d\n",sum%10);
    }
    return 0;
}</span>

 

發佈了108 篇原創文章 · 獲贊 40 · 訪問量 7萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章