HDU——1009 FatMouse' Trade (貪心水題)

Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

Sample Output

13.333
31.500

解題思路:

簡單貪心算法 , 計算單價 , 按單價從大到小排個序 , 先挑大的拿。

代碼:

#include<cstdio>
#include<algorithm>
using namespace std;

typedef struct{
    int j;    //可以換取的
    int f;    //用來換的
    double v;
}value;

value ans[1010];

bool method(value a , value b){
    return a.v > b.v;
}
int main(){
    //freopen("D://testData//1009.txt" , "r" , stdin);
    int m , n , i ;
    double result;
    while(scanf("%d %d",&m , &n) != EOF){
        if(m == -1 && n == -1)
            break;
        result = 0;
        for(i = 0 ; i < n ; i ++){
            scanf("%d %d",&ans[i].j , &ans[i].f);
            ans[i].v = (double)ans[i].j / ans[i].f;
        }

        sort(ans , ans + n  , method);

        for(i = 0 ; i < n ; i ++){
            if(m >= ans[i].f){
                result = result + ans[i].j;
                m = m - ans[i].f;
            }else{
                result = result + ans[i].v * m;
                break;
            }
        }

        printf("%.3f\n",result);

    }
    return 0;
}
發佈了89 篇原創文章 · 獲贊 138 · 訪問量 13萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章