HDU 1.3.4 What Is Your Grade?

What Is Your Grade?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3431 Accepted Submission(s): 978
 
Problem Description
“Point, point, life of student!”
This is a ballad(歌謠)well known in colleges, and you must care about your score in this exam too. How many points can you get? Now, I told you the rules which are used in this course.
There are 5 problems in this final exam. And I will give you 100 points if you can solve all 5 problems; of course, it is fairly difficulty for many of you. If you can solve 4 problems, you can also get a high score 95 or 90 (you can get the former(前者) only when your rank is in the first half of all students who solve 4 problems). Analogically(以此類推), you can get 85、80、75、70、65、60. But you will not pass this exam if you solve nothing problem, and I will mark your score with 50.
Note, only 1 student will get the score 95 when 3 students have solved 4 problems.
I wish you all can pass the exam!
Come on!
 
Input
Input contains multiple test cases. Each test case contains an integer N (1<=N<=100, the number of students) in a line first, and then N lines follow. Each line contains P (0<=P<=5 number of problems that have been solved) and T(consumed time). You can assume that all data are different when 0<p.
A test case starting with a negative integer terminates the input and this test case should not to be processed.
 
Output
Output the scores of N students in N lines for each case, and there is a blank line after each case.
 
Sample Input
4
5 06:30:17
4 07:31:27
4 08:12:12
4 05:23:13
1
5 06:30:17
-1
 
Sample Output
100
90
90
95

100
 

#include<cstdio>
#include<algorithm>
using std::sort;
 
struct Node{
    int pos, num, s, val;
} stu[102];
int arr[6];
 
bool cmp1(Node a, Node b)
{
    if(a.num == b.num) return a.s < b.s;
    return a.num > b.num;
}
 
bool cmp2(Node a, Node b)
{
    return a.pos < b.pos;
}
 
int main()
{
    int n, h, m, s, num;
    while(scanf("%d", &n) == 1 && n > 0){
        for(int i = 1; i < 6; ++i) arr[i] 

= 0;
        for(int i = 0; i < n; ++i){
            scanf("%d %d:%d:%d", &num, &h, 

&m, &s);
            s += m * 60 + h * 3600;
             
            stu[i].pos = i;
            stu[i].num = num;
            stu[i].s = s;
            stu[i].val = 100 - (5 - num) * 

10;
            ++arr[num];
        }
         
        sort(stu, stu + n, cmp1);
         
        for(int i = 4, pos = 0; i; --i){
            if(arr[i]){
                while(stu[pos].num != i) 

++pos;
                if(arr[i] == 1) stu[pos+

+].val += 5;            
                for(int j = 0; j < arr[i] 

/ 2; ++j)
                    stu[pos++].val += 5;
            }
        }
         
        sort(stu, stu + n, cmp2);
         
        for(int i = 0; i < n; ++i)
            printf("%d\n", stu[i].val);
        printf("\n");
    }
    return 0;
}


發佈了48 篇原創文章 · 獲贊 3 · 訪問量 8萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章