hdu 1503 Advanced Fruits

Advanced Fruits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2049    Accepted Submission(s): 1051
Special Judge


Problem Description
The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes, in very rare cases, a new fruit emerges that tastes like a mixture between both of them.
A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn't sound very interesting. The boss finally decides to use the shortest string that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR), and there is no shorter string that has the same property.

A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example.

Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names.
 

Input
Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters.

Input is terminated by end of file.
 

Output
For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable.
 

Sample Input
apple peach ananas banana pear peach
 

Sample Output
appleach bananas pearch
找出公共子序列,只輸出一次,標記兩個字符串特有的字符,然後遍歷輸出
 源代碼(LCS)
//hdu 1503
#include<cstdio>
#include<cstring>
#define N 210
#define max(a,b) (a>b?a:b)
char s1[N],s2[N];
int len1,len2,dp[N][N],mark[N][N];


void LCS()
{
    memset(dp,0,sizeof(dp));
    for(int i=0;i<=len1;i++)
    mark[i][0]=1;
    for(int j=0;j<=len2;j++)
    mark[0][j]=-1;
    for(int i=1;i<=len1;i++)
    {
        for(int j=1;j<=len2;j++)
        {
            if(s1[i-1]==s2[j-1])
            {
                dp[i][j]=dp[i-1][j-1]+1;
                mark[i][j]=0;
            }
            else if(dp[i-1][j]>dp[i][j-1])
            {
                dp[i][j]=dp[i-1][j];
                mark[i][j]=1;
            }
            else 
            {
                dp[i][j]=dp[i][j-1];
                mark[i][j]=-1;
            }
        }
    }
}
void PrintfLCS(int i,int j)
{
    if(!i&&!j)
        return;
    if(mark[i][j]==0)
    {
        PrintfLCS(i-1,j-1);
        printf("%c",s1[i-1]);
    }
    else if(mark[i][j]==1)
    {
        PrintfLCS(i-1,j);
        printf("%c",s1[i-1]);
    }
    else 
    {
        PrintfLCS(i,j-1);
        printf("%c",s2[j-1]);
    }
}
int main()
{
    while(~scanf("%s%s",s1,s2))
    {
        len1=strlen(s1);
        len2=strlen(s2);
        LCS();
        PrintfLCS(len1,len2);
        printf("\n");
    }
    return 0;
}


發佈了54 篇原創文章 · 獲贊 1 · 訪問量 2萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章