POJ 1006 Biorhythms【中國剩餘定理】

Description

Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and 33 days, respectively. There is one peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental). For example, if it is the mental curve, thought processes will be sharper and concentration will be easier. 
Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give the number of days to the next occurrence of a triple peak. 

Input

You will be given a number of cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical, emotional, and intellectual cycles peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date. The end of input is indicated by a line in which p = e = i = d = -1.

Output

For each test case, print the case number followed by a message indicating the number of days to the next triple peak, in the form: 

Case 1: the next triple peak occurs in 1234 days. 

Use the plural form ``days'' even if the answer is 1.

Sample Input

0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1

Sample Output

Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.

/*
    題意:人自出生起就有體力,情感和智力三個生理週期,分別爲23,28和33天.一個週期內有一天爲峯值,
         現在給出三個日期,分別對應於體力,情感,智力出現峯值的日期.然後再給出一個起始日期,
         要求從這一天開始,算出最少再過多少天后三個峯值同時出現.
    類型:中國剩餘定理
    分析:由 x % 23 = 日期1; x % 28 = 日期2; x % 33 = 日期3.
         23,28,33兩兩互質,很快可以看出,這道題是考中國剩餘定理的裸題,直接套上剛學的模版
*/

#include<cstdio>
#include<iostream>
#include<algorithm>
typedef long long LL;
const int maxn = 100005;
void ex_gcd(LL a, LL b, LL &x, LL &y, LL &d){
    if (!b) {d = a, x = 1, y = 0;}
    else{
        ex_gcd(b, a % b, y, x, d);
        y -= x * (a / b);
    }
}
LL inv(LL t, LL p){//如果不存在,返回-1
    LL d, x, y;
    ex_gcd(t, p, x, y, d);
    return d == 1 ? (x % p + p) % p : -1;
}
LL china(int n, LL *a, LL *m){//中國剩餘定理
    LL M = 1, ret = 0;
    for(int i = 0; i < n; i ++) M *= m[i];
    for(int i = 0; i < n; i ++){
        LL w = M / m[i];
        ret = (ret + w * inv(w, m[i]) * a[i]) % M;
    }
    return (ret + M) % M;
}
LL p[3]={23,28,33},r[3],d,ans,MOD=21252;//MOD=23*28*33表示三個週期恰好爲同一天需要的週期
int main(){
    int cas=0;
    while(~scanf("%I64d%I64d%I64d%I64d",&r[0],&r[1],&r[2],&d)){
        if(r[0]+r[1]+r[2]+d==-4)break;
        ans = ((china(3, r, p) - d) % MOD + MOD) % MOD;//獲得最小天數
        printf("Case %d: the next triple peak occurs in %I64d days.\n", ++cas,ans?ans:MOD);
    }
}



發佈了128 篇原創文章 · 獲贊 8 · 訪問量 6萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章