HDU 1102 Constructing Roads【最小生成樹】

Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum. 

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j. 

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built. 

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. 

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

Source


Prime  算法

/*
    HDU 1102 Constructing Roads
    題意:給定n個村莊的道路情況,在q個道路已經建成的情況下求最小生成樹
    類型:最小生成樹
    分析:把建好的道路費用改爲0,跑一遍最小生成樹就行.寫這道題是想複習一下圖論,嗯,就醬紫..
*/
#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
const int INF = 0x7fffffff;
const int maxn = 105;
int lowcost[maxn],vis[maxn],Map[maxn][maxn];
int n;
int prime(){
    int next;
    int Min,mincost=0;
    memset(vis,0,sizeof(vis));
    for(int i=1;i<=n;i++)
        lowcost[i]=Map[1][i];
    vis[1]=1;
    for(int i=1;i<n;i++){
        Min=INF;
        for(int j=1;j<=n;j++){
            if(!vis[j]&&Min>lowcost[j]){
                Min=lowcost[j];next=j;
            }
        }
        mincost+=Min;
        vis[next]=1;
        for(int j=1;j<=n;j++){
            if(!vis[j]&&lowcost[j]>Map[next][j]){
                lowcost[j]=Map[next][j];
            }
        }
    }
    return mincost;
}
int main()
{
    int q,x,y;
    while(scanf("%d",&n)!=EOF){
        for(int i=0;i<=n;i++)
            for(int j=0;j<=n;j++)
                Map[i][j]=INF;
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++){
                scanf("%d",&Map[i][j]);
            }
        }
        cin>>q;
        while(q--){
            scanf("%d%d",&x,&y);
            Map[x][y]=Map[y][x]=0;
        }
        printf("%d\n",prime());
    }
    return 0;
}

Kruskal 算法:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
const int INF = 0x7fffffff;
const int maxm = 10005;
int fa[maxm];
struct Edge{
    int dis,u,v;
    Edge(int u,int v,int dis):u(u),v(v),dis(dis){}
    Edge(){}
}edge[maxm];
bool cmp(Edge a,Edge b){
    return a.dis<b.dis;
}
int Find(int x){
    return x==fa[x]?x:x=Find(fa[x]);
}
void unit(int x,int y){
    x=Find(x);y=Find(y);
    if(x!=y)fa[x]=y;
}
int main()
{
    int n,q,res;
    int x,y,cnt,d;
    while(scanf("%d",&n)!=EOF){
        cnt=0,res=0;
        for(int i=1;i<=n;i++){
            fa[i]=i;
            for(int j=1;j<=n;j++){
                scanf("%d",&d);
                if(j>i){
                    edge[cnt++]=Edge(i,j,d);
                }
            }
        }
        sort(edge,edge+cnt,cmp);
        cin>>q;
        while(q--){
            scanf("%d%d",&x,&y);
            unit(x,y);
        }
        for(int i=0;i<cnt;i++){
            if(Find(edge[i].u)!=Find(edge[i].v)){
                unit(edge[i].u,edge[i].v);
                res+=edge[i].dis;
            }
        }
        printf("%d\n",res);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章