VJ--圖論---BFS搜索啊搜索,又改了好久,原因是:首先是第一個忘記標記啦,後來又發現隊列開小啦,各種錯啊!!

A - Oil Deposits
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2


#include <stdio.h>
#include <stdlib.h>
#include <string.h>
char map[105][105];
int vis[105][105];
int mv[8][2]= {{1,0},{0,1},{-1,0},{0,-1},{1,1},{-1,1},{1,-1},{-1,-1}};
int s;
int m,n;
struct A
{
    int x;
    int y;
} p[10050];
int enter=0,out=0;
struct A f,t;
int getdian()
{
    int i,j;
    for(i=0; i<m; i++)
    {
        for(j=0; j<n; j++)
        {
            if(map[i][j]=='@'&&!vis[i][j])
                break;
        }
        if(j<n)
            break;
    }
    if(i>=m&&j>=n)
        return s;
    else
    {
        s++;
        vis[i][j]=1;
        BFS(i,j);
    }
}
void BFS(int x,int y)
{
    int i;
    f.x=x;
    f.y=y;
    p[enter++]=f;
    while(out<enter)
    {
        t=p[out++];
        for(i=0; i<8; i++)
        {
            f.x=t.x+mv[i][0];
            f.y=t.y+mv[i][1];
            if(0<=f.x&&f.x<m&&0<=f.y&&f.y<n&&!vis[f.x][f.y]&&map[f.x][f.y]=='@')
            {
                vis[f.x][f.y]=1;
                p[enter++]=f;
            }
        }
    }
    if(out>=enter)
        getdian();
}
int main()
{
    int i;
    int t;
    while(~scanf("%d%d",&m,&n)&&m&&n)
    {
        memset(vis,0,sizeof(vis));
        s=0;
        for(i=0; i<m; i++)
            scanf("%*c%s",map[i]);
        printf("%d\n",getdian());
    }
    return 0;
}

發佈了31 篇原創文章 · 獲贊 0 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章