Discovering Gold(基礎概率dp)

You are in a cave, a long cave! The cave can be represented by a 1 x N grid. Each cell of the cave can contain any amount of gold.

Initially you are in position 1. Now each turn you throw a perfect 6 sided dice. If you get X in the dice after throwing, you add X to your position and collect all the gold from the new position. If your new position is outside the cave, then you keep throwing again until you get a suitable result. When you reach the Nth position you stop your journey. Now you are given the information about the cave, you have to find out the expected number of gold you can collect using the given procedure.

Input
Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a blank line and an integer N (1 ≤ N ≤ 100) denoting the dimension of the cave. The next line contains N space separated integers. The ith integer of this line denotes the amount of gold you will get if you come to the ith cell. You may safely assume that all the given integers will be non-negative and no integer will be greater than 1000.

Output
For each case, print the case number and the expected number of gold you will collect. Errors less than 10-6 will be ignored.

Sample Input
3

1
101

2
10 3

3
3 6 9
Sample Output
Case 1: 101.0000000000
Case 2: 13.000
Case 3: 15

概率的題目,算是自己刷的第一道。
給出n個點,每個點都有金子,然後從第一個點開始,每次進行擲骰子,6個面的,然後按照骰子上面的顯示數字走幾步,注意,要是骰子上的步數在隧道外,則重新投擲。

假定在最後一個地方,則獲得的數目爲dp[i];
在n-1個地方,則獲得的數目爲dp[i]+dp[i+1];(骰子數目有1種情況)
在n-2個地方,。。。。。。。dp[i]+dp[i+1]/2+dp[i+2]/2(骰子數目有兩種情況)
…………………..

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <set>
#include <cstring>
#include <cstdlib>
#include <vector>
using namespace std;
double dp[123123];
int main()
{
    int t;
    scanf("%d", &t);
    for(int T=1;T<=t;T++)
    {
        int n;
        scanf("%d", &n);
        for(int i=1;i<=n;i++)
        {
            scanf("%lf", &dp[i]);
        }
        for(int i=n-1;i>=1;i--)
        {
            int k = min(6, n-i);
            double temp = 0;
            for(int j=i+1;j<k+i+1;j++)
                temp += dp[j];
            dp[i] = dp[i] + temp/k;
        }
        printf("Case %d: %lf\n", T, dp[1]);
    }
    return 0;
}
發佈了378 篇原創文章 · 獲贊 55 · 訪問量 10萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章