(樹形DP)Strategic game poj1463

Description

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him? 

Your program should find the minimum number of soldiers that Bob has to put for a given tree. 

For example for the tree: 


the solution is one soldier ( at the node 1).

Input

The input contains several data sets in text format. Each data set represents a tree with the following description: 


  • the number of nodes 
  • the description of each node in the following format 
    node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifiernumber_of_roads 
    or 
    node_identifier:(0) 


The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500);the number_of_roads in each line of input will no more than 10. Every edge appears only once in the input data.

Output

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following:

Sample Input

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output

1
2

Source

Southeastern Europe 2000

求樹上的最小值

#include<iostream>
#include<vector>
#include<algorithm>
#include<cstdio>
#include<cstring>
using  namespace std;
const int maxn=1e4;
int dp[maxn][2];
int father[maxn];

vector<int>mapp[maxn];

void debug()
{
    cout<<"____five_____"<<endl;
}

void dfs(int root)
{
    //從root開始搜索
    for(int i=0; i<mapp[root].size(); ++i)
    {
        int v=mapp[root][i];
        dfs(v);
        dp[root][0]+=dp[v][1];
        dp[root][1]+=min(dp[v][0],dp[v][1]);
    }
    return ;
}

void init(int n)
{
    for(int i=0; i<=n; ++i)
    {
        father[i]=-1;
        dp[i][1]=1,dp[i][0]=0;
        mapp[i].clear();
    }
}

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        int u,num,v;
        init(n);
        for(int i=1; i<=n; ++i)
        {
            scanf("%d:(%d)",&u,&num);
            for(int j=0; j<num; ++j)
            {
                scanf("%d",&v);
                mapp[u].push_back(v);
                father[v]=u;
            }
        }
        //連通完畢。
        int root=1;
        while(father[root]!=-1)
        {
//            debug();
            root=father[root];
        }
        dfs(root);
        printf("%d\n",min(dp[root][1],dp[root][0]));
    }
    return 0;
}

 

發佈了205 篇原創文章 · 獲贊 36 · 訪問量 7萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章