【HD 1213】How Many Tables

How Many Tables

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24377 Accepted Submission(s): 12202

Problem Description
Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output
2
4

Author
Ignatius.L

Source
杭電ACM省賽集訓隊選拔賽之熱身賽

—————————————————————————————————————————————————

和暢通工程完全一樣的題,本質上是求根節點數,有多少個根節點就說明有多少桌。詳解可以查看 -> 傳送門<-對,就是他

——————————————————————————————————————————————

#include<cstdio>
#include<cstring>

//一樣求根節點數目

using namespace std;

const int MAX_N = 1005; 
int par[MAX_N];
int rank[MAX_N];

void init( int n )
{
    for( int i=1; i<=n; i++ )
    {
        par[i] = i;
        rank[i] = 0;
    }
} 

int find( int x )
{
    if( par[x] == x )
    return x;
    else
    return find(par[x]);
}

void unite( int x,int y )
{
    x = find(x);
    y = find(y);
    if( x == y ) return;
    if( rank[x] < rank[y] )
    {
        par[x] = y;
    }else{
        par[y] = x;
        if( rank[x] == rank[y] ) rank[x]++;
    }
//  par[x]=y;
}

int main()
{
    int n,m,a,b;
    int t; 
    scanf("%d",&t);
    while( t-- )
    {
        scanf("%d",&n); 
        init(n);
        scanf("%d",&m);
        for( int i=0; i<m; i++ )
        {
            scanf("%d%d",&a,&b);
            unite(a,b);
        }
        int count=0;
        for( int i=1; i<=n; i++ )
        {
            if( par[i] == i )
            count++;
        }
        printf("%d\n",count);
    }
}





發佈了62 篇原創文章 · 獲贊 6 · 訪問量 3萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章