【POJ 1611】The Suspects

The Suspects

Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 33378 Accepted: 16192
Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output

For each case, output the number of suspects in one line.
Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output

4
1
1
Source

—————————————————————————————————————————————————

這一題用自己的方法比較麻煩,就是先分集合,再搜索元素個數,逐個加一,容易錯,看了一下別人的題解,思維很巧妙,用rank控制和0 同一集合的元素的個數,連接成一條直線,在合併時直接相加,最後求長度。不失爲一種很好的辦法。就是適用性不強。

————————————————————————————————————————————————

#include<cstdio>
#include<iostream>

using namespace std;

int const MAX_N = 30010;  

int par[MAX_N];           
int rankk[MAX_N];       
int student[505];

void init( int n )
{
    for( int i=0; i<n; i++ )
    {
        par[i]=i;
        rankk[i]=1; //全部先設爲1,方便後面求長度
    }
} 

int find( int x )
{
    if( par[x] == x )
    return x;
    else return find(par[x]);  
}

void unite( int x, int y )
{
    x = find(x);
    y = find(y);
    if( x == y ) return;
    if( rankk[x] < rankk[y] )
    {
        par[x] = y;
        rankk[y] = rankk[x]+rankk[y];//關鍵
    }else
    {
        par[y] = x;
        rankk[x] = rankk[x]+rankk[y];
    }
}

int main()
{
    int n,m,k,a,b;
    int first,next;
    while( ~scanf("%d%d",&n,&m),n||m )
    {
        if( m == 0 ){
            printf("1\n");
            continue;
        }
        init(n);
        for( int i=0; i<m; i++ )
        {
            scanf("%d",&k);
            scanf("%d",&first);
            for( int j=1; j<k; j++ )
            {
                scanf("%d",&next);
                unite(first,next);
            }
        }
    // 廢置代碼
    //  int count = 0;
    //  for( int i=1; i<=n; i++ )
    //  {
    //      if( find(0) == find(i) )
    //      count++;
    //  }
        printf("%d\n",rankk[par[0]]);
    }
}






發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章