poj 1328Radar Installation

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d .

We use Cartesian coordinate system, defining the coasting is the x -axis. The sea side is above x -axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x - y coordinates.

\epsfbox{p2519.eps}

Input

The input consists of several test cases. The first line of each case contains two integers n(1$ \le$n$ \le$1000) and d , where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros.

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. `-1' installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1
題意:

題意:假設海岸線是一條無限延伸的直線,陸地在海岸線的一側,而海洋在另一側。每一個小的島嶼是海洋上的一個點,雷達坐落於海岸線上,只能覆蓋d距離,所以如果小島能夠被覆蓋到的話,它們之間的距離最多爲d,題目要求計算出能夠覆蓋給出的所有島嶼的最少雷達數目。果不能覆蓋,輸出-1。

思路:我們可以以點來做半徑爲d的圓,與x軸的相交,如果不相交那麼肯定完不成任務,反之就轉化成了區間選點問題。

代碼:

<span style="font-size:14px;">#include<stdio.h>
#include<iostream>
#include<math.h>
#include<algorithm>//sort所在的庫文件,排序用
using namespace std;
const int MAXN=1005;
struct Line
{
    double l,r;
}line[MAXN];//每個島作半徑爲d的圓,與x軸所截的線段

bool cmp(Line a,Line b)
{
    
    return a.l<b.l;
}       //按照線段的左端點從小到大排序
int main()
{
    //freopen("test.in","r",stdin);
    //freopen("test.out","w",stdout);
    int n,d;
    int i;
    int x,y;
    bool yes;//確定是不是有解
    int icase=1;
    while(cin>>n>>d)
    {
        yes=true;
        int cnt=0;
        if(n==0&&d==0)break;
        for(i=0;i<n;i++)
        {
            cin>>x>>y;
            if(yes==false)continue;
            if(y>d)yes=false;
            else
            {
                line[i].l=(double)x-sqrt((double)d*d-y*y);
                line[i].r=(double)x+sqrt((double)d*d-y*y);
            }    
        }
        if(yes==false)
        {
            cout<<"Case "<<icase++<<": -1"<<endl;
            continue;
        }
        sort(line,line+n,cmp);
        cnt++;
        double now=line[0].r;
        for(i=1;i<n;i++)
        {
            
            if(line[i].r<now)
               now=line[i].r;
            else if(now<line[i].l)
            {
                now=line[i].r;
                cnt++;
            }    
        }
        cout<<"Case "<<icase++<<": "<<cnt<<endl;    
                
    }     
    return 0;
}</span>


發佈了76 篇原創文章 · 獲贊 7 · 訪問量 4萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章