poj 3903

Description

The world financial crisis is quite a subject. Some people are more relaxed while others are quite anxious. John is one of them. He is very concerned about the evolution of the stock exchange. He follows stock prices every day looking for rising trends. Given a sequence of numbers p1, p2,...,pn representing stock prices, a rising trend is a subsequence pi1 < pi2 < ... < pik, with i1 < i2 < ... < ik. John’s problem is to find very quickly the longest rising trend.

Input

Each data set in the file stands for a particular set of stock prices. A data set starts with the length L (L ≤ 100000) of the sequence of numbers, followed by the numbers (a number fits a long integer).
White spaces can occur freely in the input. The input data are correct and terminate with an end of file.

Output

The program prints the length of the longest rising trend.
For each set of data the program prints the result to the standard output from the beginning of a line.

Sample Input

6 
5 2 1 4 5 3 
3  
1 1 1 
4 
4 3 2 1

Sample Output

3 
1 
1

Hint

There are three data sets. In the first case, the length L of the sequence is 6. The sequence is 5, 2, 1, 4, 5, 3. The result for the data set is the length of the longest rising trend: 3.


題意:
給定L個整數A1,A2,...,An,按照從左到右的順序選出儘量多的整數,組成一個上升序列(子序列可以理解爲:刪除0個或者多個數,其他的數的吮吸不變)。例如,1,6,2,3,7,5,可以選出上升子序列1,2,3,5,也可以選出1,6,7,但前者更長,選出的上升子序列中相鄰元素不能相等。
思路:
開闢一個棧,每次取棧頂元素s和讀到的元素a做比較,如果a>s,  則加入棧;如果a<s,則二分查找棧中的比a大的第1個數,並替換。  最後序列長度爲棧的長度。 
代碼:
#include<cstdio>
using namespace std;
int const size=100010;
int stack[size];
int main()
{
    int L;
    int top,temp;
    while(scanf("%d",&L)!=EOF)
    {
        top=0;
        stack[0]=-1;//第一個數可能爲0
        for(int i=0;i<L;i++)
        {
            scanf("%d",&temp);
            if(temp>stack[top])//比棧頂大的元素就入棧
            {
                stack[++top]=temp;
            }
            else
            {
                int left=1,right=top;
                int mid;
                while(left<=right)//二分檢索棧中第一個比temp大的元素
                {
                    mid=(left+right)/2;
                    if(temp>stack[mid])
                        left=mid+1;
                    else
                        right=mid-1;
                }
                stack[left]=temp;
            }
        }
        printf("%d\n",top);
    }
    return 0;
}

發佈了76 篇原創文章 · 獲贊 7 · 訪問量 4萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章