poj 1505

Description

Before the invention of book-printing, it was very hard to make a copy of a book. All the contents had to be re-written by hand by so calledscribers. The scriber had been given a book and after several months he finished its copy. One of the most famous scribers lived in the 15th century and his name was Xaverius Endricus Remius Ontius Xendrianus (Xerox). Anyway, the work was very annoying and boring. And the only way to speed it up was to hire more scribers.


Once upon a time, there was a theater ensemble that wanted to play famous Antique Tragedies. The scripts of these plays were divided into many books and actors needed more copies of them, of course. So they hired many scribers to make copies of these books. Imagine you have m books (numbered $1, 2, \dots, m$) that may have different number of pages ( $p_1, p_2, \dots, p_m$) and you want to make one copy of each of them. Your task is to divide these books among k scribes, $k \le m$. Each book can be assigned to a single scriber only, and every scriber must get a continuous sequence of books. That means, there exists an increasing succession of numbers $0 = b_0 < b_1 < b_2, \dots < b_{k-1} \le b_k = m$ such that i-th scriber gets a sequence of books with numbers between bi-1+1 and bi. The time needed to make a copy of all the books is determined by the scriber who was assigned the most work. Therefore, our goal is to minimize the maximum number of pages assigned to a single scriber. Your task is to find the optimal assignment.

Input 

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly two lines. At the first line, there are two integers m and k, $1 \le k \le m \le 500$. At the second line, there are integers $p_1, p_2, \dots p_m$ separated by spaces. All these values are positive and less than 10000000.

Output 

For each case, print exactly one line. The line must contain the input succession $p_1, p_2, \dots p_m$ divided into exactly k parts such that the maximum sum of a single part should be as small as possible. Use the slash character (`/') to separate the parts. There must be exactly one space character between any two successive numbers and between the number and the slash.


If there is more than one solution, print the one that minimizes the work assigned to the first scriber, then to the second scriber etc. But each scriber must be assigned at least one book.

Sample Input 

2
9 3
100 200 300 400 500 600 700 800 900
5 4
100 100 100 100 100

Sample Output 

100 200 300 400 500 / 600 700 / 800 900
100 / 100 / 100 / 100 100



Miguel A. Revilla
2000-02-15
題意:把m個連續的序列分成連續的k個子序列,設第i個連續的子序列的和爲S(i),你的程序要儘量讓最大的連續的子序列和S(i)最大值最小。輸出用‘/'隔開來,如果有多種方案,讓後面的數的和儘量最大。
思路:
用一般的方法能夠解出來,但是由於時間限制,會超時,因此,我們必須優化算法,可以參考算法競賽與入門經典(劉汝佳)中的P228 二分查找,找出那個連續的最大和的最小值。然後按要求輸出即可。
代碼:
#include<cstdio>
#include<cstring>
using namespace std;
int book[505];
bool flag[505];
int m,k;
int cnt;
int copy(long long x)
{
    cnt=1;
    long long sum=0;
    memset(flag,false,sizeof(flag));
    for(int i=m-1;i>=0;i--)
    {
        sum+=book[i];
        if(sum>x)
        {
            cnt++;
            sum=book[i];
            flag[i]=true;
        }

    }
    return cnt;
}
void print()
{
    printf("%d",book[0]);
    for(int i=1;i<m;i++)
    {
        if(flag[i-1])   printf(" /");
        printf(" %d",book[i]);
    }
    printf("\n");

}
int main()
{
        int T;
        long long l,r;
        scanf("%d",&T);
        while(T--)
        {
            scanf("%d%d",&m,&k);
            l=r=0;
            for(int i=0;i<m;i++)
            {
                scanf("%d",&book[i]);
                if(book[i]>l)    l=book[i];
                r+=book[i];

            }
            long long mid;
            while(l<r)
            {
                mid=(l+r)/2;
                if(copy(mid)<=k)    r=mid;
                else l=mid+1;
            }
            int cnt=copy(r);
            for(int i=0;i<m&&cnt<k;i++)
            {
                if(!flag[i])   flag[i]=true,cnt++;


            }
          print();

        }
    return 0;
}


發佈了76 篇原創文章 · 獲贊 7 · 訪問量 4萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章