[POJ2352]Star

不懂英語的直接點這裏

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

Description

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it’s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

題目大意

給定一個星座的直角座標圖,每個星星都有一個座標值(x,y)(0<=X,Y<=32000);其中輸入中的y是不下降的,對於y相同的情況,則按x不下降的順序給出。

給出N(1<=N<=15000)個星星的座標,輸出等級分別爲0,1,2 3,4,…的星星的個數。星星的等級的定義是:如果有m個星星的座標(x,y)均小於等於該星星的座標(x0,y0)則該星星的等級爲m(m中不包含該星星本身)。

分析

因爲這道題的數據規模較大,可以使用樹狀數組來解決。
依次讀入輸入數據,只處理其x值即可,即update(x,1),此時sum(x)-1即爲此顆星星左下方的星星個數。

源代碼

#include<cstdio>
#include<cstring>
#include<cstdlib>
#define lowbit(x) ((x)&(-x))
#define N 35000
#define M 16000
int c[N],ans[M];
int n;
void update(int p,int x){
    while(p<=32001){
        c[p]+=x;
        p+=lowbit(p);
    }
}
int sum(int p){
    int sum=0;
    while(p>0){
        sum+=c[p];
        p-=lowbit(p);
    }
    return sum;
}
int main()
{
    int i,x,y;
    scanf("%d",&n);
    memset(c,0,sizeof(c));
    memset(ans,0,sizeof(ans));
    for(i=1;i<=n;i++){
        scanf("%d%d",&x,&y);
        ans[sum(x+1)]++;
        update(x+1,1);
    }
    for(i=0;i<n;i++)
        printf("%d\n",ans[i]);
}
發佈了80 篇原創文章 · 獲贊 134 · 訪問量 24萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章