POJ 2253 Frogger

題目描述:

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

解題報告:

1:稍微修改下模板:具體可以看代碼註釋部分。選c++提交,很無語=.=,換行也要注意。

2:代碼1是Dijkstra的優化模板。g:保存地圖。dis:從源點到每個點的可行路徑的最長邊的最小值。x:保存x座標,y:保存y座標。visit:標記數組。point中的id爲每個點的編號,dis爲距離。Q爲優先隊列,距離小的排在前面。

3:代碼2是SPFA的模板。cnt:每個點入隊次數,大於n說明出現負環。g:保存地圖。dis:從源點到每個點的可行路徑的最長邊的最小值。x:保存x座標,y:保存y座標。visit:標記數組。point中的id爲每個點的編號,dis爲距離。Q爲隊列。

代碼1:

#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
#include<cmath>
using namespace std;
typedef long long ll;
const ll N = 200+10;
const ll INF = 0x3f3f3f3f;
double g[N][N], dis[N], x[N], y[N];
bool visit[N];
struct point{
    ll id;
    double dis;
    bool operator < (point x)const {
        return dis > x.dis;
    }
}p1, p2;
priority_queue<point> Q;
void init(ll n){
    memset(visit, 0, sizeof(visit));
    for(ll i=0; i<n; ++i)dis[i] = INF;
    while(!Q.empty())Q.pop();
    for(ll i=0; i<n; ++i)scanf("%lf%lf", x+i, y+i);
    for(ll i=0; i<n; ++i)
        for(ll j=0; j<n; ++j)g[i][j] = g[j][i] = sqrt(pow(x[i]-x[j], 2) + pow(y[i]-y[j], 2));
}
void Dijkstra(ll s, ll n){
    p1.id = s, p1.dis = 0, dis[s] = 0;
    Q.push(p1);
    while(!Q.empty()){
        p1 = Q.top();
        Q.pop();
        if(visit[p1.id])continue;
        visit[p1.id] = 1;
        for(ll i=0; i<n; ++i){
            if(!visit[i] && max(g[p1.id][i], dis[p1.id]) < dis[i]){//修改
                dis[i] = p2.dis = max(g[p1.id][i], dis[p1.id]);
                p2.id = i, Q.push(p2);
            }
        }
    }
}
int main(){
    ll n, cas = 1;
    while(~scanf("%lld", &n) && n){
        init(n);
        Dijkstra(0, n);
        printf("Scenario #%lld\nFrog Distance = %.3lf\n\n", cas++, dis[1]);
    }
    return 0;
}

代碼2:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
using namespace std;
typedef long long ll;
const ll N = 200+10;
const ll INF = 0x3f3f3f3f;
ll cnt[N];
double g[N][N], dis[N], x[N], y[N];
bool visit[N];
struct point{
    ll id;
    double dis;
}p1, p2;
queue<point> Q;
void init(ll n){
    for(ll i=0; i<n; ++i)dis[i] = INF, cnt[i] = 0, visit[i] = 0;
    while(!Q.empty())Q.pop();
    for(ll i=0; i<n; ++i)scanf("%lf%lf", x+i, y+i);
    for(ll i=0; i<n; ++i)
        for(ll j=0; j<n; ++j)g[i][j] = g[j][i] = sqrt(pow(x[i]-x[j], 2) + pow(y[i]-y[j], 2));
}
bool SPFA(ll s, ll n){
    p1.id = s, p1.dis = 0, dis[s] = 0, cnt[s] = 1;
    Q.push(p1);
    while(!Q.empty()){
        p1 = Q.front();
        Q.pop(), visit[p1.id] = 0;
        for(ll i=0; i<n; ++i){
            if(max(dis[p1.id], g[p1.id][i]) >= dis[i])continue;//修改
            p2.dis = dis[i] = max(dis[p1.id], g[p1.id][i]);
            if(visit[i])continue;
            visit[i] = 1, p2.id = i, cnt[i]++;
            if(cnt[i] > n)return 0;
            Q.push(p2);
        }
    }
    return 1;
}
int main(){
    ll n, cas = 1;
    while(~scanf("%lld", &n) && n){
        init(n);
        if(SPFA(0, n))printf("Scenario #%lld\nFrog Distance = %.3lf\n\n", cas++, dis[1]);
    }
    return 0;
}

 

發佈了211 篇原創文章 · 獲贊 9 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章