hdu 5477__A Sweet Journey

A Sweet Journey

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 403    Accepted Submission(s): 223


Problem Description
Master Di plans to take his girlfriend for a travel by bike. Their journey, which can be seen as a line segment of length L, is a road of swamps and flats. In the swamp, it takes A point strengths per meter for Master Di to ride; In the flats, Master Di will regain B point strengths per meter when riding. Master Di wonders:In the beginning, he needs to prepare how much minimum strengths. (Except riding all the time,Master Di has no other choice) 

 

Input
In the first line there is an integer t (1t50), indicating the number of test cases.
For each test case:
The first line contains four integers, n, A, B, L.
Next n lines, each line contains two integers: Li,Ri, which represents the interval [Li,Ri] is swamp.
1n100,1L105,1A10,1B101Li<RiL.
Make sure intervals are not overlapped which means Ri<Li+1 for each i (1i<n).
Others are all flats except the swamps.
 

Output
For each text case:
Please output “Case #k: answer”(without quotes) one line, where k means the case number counting from 1, and the answer is his minimum strengths in the beginning.
 

Sample Input
1 2 2 2 5 1 2 3 4
 

Sample Output
Case #1: 0
 

Source
 
#include<cstdio>
int main()
{
    int t,n,l[110],r[110];
    scanf("%d",&t);
    int ans,A,B,L,cas=1;
    while(t--) {
        scanf("%d%d%d%d",&n,&A,&B,&L);  //  A代表cost
        int now=0,ans=0;
        for(int i=0;i<n;i++) {
            scanf("%d%d",&l[i],&r[i]);
            if(i==0) {
                if(l[i]>0) {
                    now+=(l[i]-0)*B;
                }
            }
            else {
                now+=(l[i]-r[i-1])*B;
            }
            int cnt=(r[i]-l[i])*A;
            if(now<cnt) {
                ans+=cnt-now;
                now=0;
            }
            else {
                now-=cnt;
            }
        }
        printf("Case #%d: %d\n",cas++,ans);
    }
    return 0;
}


發佈了51 篇原創文章 · 獲贊 1 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章