EASY_ZJU_PAT_ADVANCED LEVEL 1050 高效輸入含有空格的字符串 高效刪除字符串中的字符

1050. String Subtraction (20)

時間限制
10 ms
內存限制
32000 kB
代碼長度限制
16000 B
判題程序
Standard

Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1 - S2 in one line.

Sample Input:
They are students.
aeiou
Sample Output:
Thy r stdnts.
NOTE:
1.通常的cin和scanf("%s",*char)這種遇到空格會停止,有系統內置的函數可以實現連續帶空格的輸入,gets(char*)和getline(cin,string),但是這兩種的效率都不是很高。可以用
	while(scanf("%c",*char)&&ch!='\n'){
	}
	這種形式進行帶有空格的字符串輸入
2.這道題思路不難,但是重點就在如何減少運行時間。要不然會出現超時的情況。
/************************************************
	@ AUTHOR	: GAOMINQUAN
	@ DATA		: 2014 - 2 - 24
	@ MAIL		: [email protected]
	@ HARD		: EASY ***

/************************************************/
#include<iostream>
#include<vector>
#include<string.h>
using namespace std;
const int M = 10000;
const int charNum = 127;
int main(){
	char line1[M];
	vector<int> charMark(charNum,0);
	char ch;
	int index1 = 0;

	while(scanf("%c",&ch)&&ch!='\n'){
		line1[index1++] = ch;
	}
	while(scanf("%c",&ch)&&ch!='\n'){
		int index = ch;
		charMark[index] = -1;
	}

	for(int line1Index = 0; line1Index<index1; line1Index++){
		int index = line1[line1Index];
		if(charMark[index] == 0){
			printf("%c",line1[line1Index]);
		}
	}
	cout<<endl;
	return 0;

}


發佈了40 篇原創文章 · 獲贊 3 · 訪問量 8萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章