1004. Counting Leaves (30)

題目:

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.
Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output “0 1” in a line.

Sample Input
2 1
01 1 02
Sample Output
0 1

解答1:

//DFS方法: 
#include<cstdio>
#include<algorithm>
#include<vector>
using namespace std;
const int MAXV=110;
vector<int> Node[MAXV];
int leaf[MAXV]={0};
int maxDepth=1;//樹的整體深度 
void DFS(int index,int depth){
    maxDepth=max(depth,maxDepth);
    if(Node[index].size()==0){
        leaf[depth]++;
        return;
    }
    for(int i=0;i<Node[index].size();i++){
        DFS(Node[index][i],depth+1);
    }
}
int main(){
    int n,m;
    scanf("%d%d",&n,&m);
    int father,k,child;
    for(int i=0;i<m;i++){
        scanf("%d%d",&father,&k);
        for(int j=0;j<k;j++){
            scanf("%d",&child);
            Node[father].push_back(child);
        }
    } 
    DFS(1,1);
    for(int i=1;i<=maxDepth;i++){//maxDepth而不是n 
        if(i!=1)printf(" ");
        printf("%d",leaf[i]);
    }
    return 0;
}

解答2:

//BFS方法:
#include<cstdio>
#include<queue>
#include<vector>
using namespace std;

const int MAXV=110;
vector<int> Node[MAXV];
int Depth[MAXV]={0};
int leaf[MAXV]={0};
int maxDepth=0;

void BFS(){
    queue<int> Q;
    Q.push(1);
    while(!Q.empty()){
        int index=Q.front();
        Q.pop();
        maxDepth=max(maxDepth,Depth[index]);
        if(Node[index].size()==0)leaf[Depth[index]]++;
        for(int i=0;i<Node[index].size();i++){
            Depth[Node[index][i]]=Depth[index]+1;
            Q.push(Node[index][i]);
        }
    }
}
int main(){
    int n,m;
    scanf("%d%d",&n,&m);
    int father,k,child;
    for(int i=0;i<m;i++){
        scanf("%d%d",&father,&k);
        for(int j=0;j<k;j++){
            scanf("%d",&child);
            Node[father].push_back(child);
        }
    } 
    Depth[1]=1;
    BFS();
    for(int i=1;i<=maxDepth;i++){//maxDepth而不是n 
        if(i!=1)printf(" ");
        printf("%d",leaf[i]);
    }
    return 0;
}
發佈了185 篇原創文章 · 獲贊 14 · 訪問量 7萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章