Leading and Trailing 快速冪和cmath函數(modf函數,log10函數,pow函數)

You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.

Input
Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107).

Output
For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that nk contains at least six digits.

Sample Input
5
123456 1
123456 2
2 31
2 32
29 8751919
Sample Output
Case 1: 123 456
Case 2: 152 936
Case 3: 214 648
Case 4: 429 296

Case 5: 665 669

題意:

很好理解,就是求一個數的前三位和最後三位。

後三位好求,快速冪mod=1000,結果就是後三位。

前三位用modf函數求x=lg(n^k)的小數部分,然後10^x*100就是前三位,也就是ans=10^(x+2);

還要注意一點,最後三位前兩位可能有0,如003,這時用%03lld,(設定長度爲三,不足用0填充),輸出就爲003,而不是3。

#include<cstdio>
#include<cmath>
using namespace std;
typedef long long ll;
const int mod=1000;

ll powmod(ll x,ll n)
{
    if(n==0) return 1%mod;
    ll temp=powmod(x,n>>1);
    temp=temp*temp%mod;
    if(n&1) temp=temp*x%mod;
    return temp;
}

int main()
{
    int t;
    ll n,k;
    scanf("%d",&t);
    for(int i=1;i<=t;++i)
    {
        double intpart;
        scanf("%lld%lld",&n,&k);
        int ans=(int)pow(10.0, 2.0 + modf((double)k * log10(n), &intpart));
        printf("Case %d: %d %03lld\n",i,ans,powmod(n,k));
    }
    return 0;
}

發佈了45 篇原創文章 · 獲贊 3 · 訪問量 2萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章