POJ 3096 Surprising Strings


                                                         Surprising Strings
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6884   Accepted: 4457

Description

The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its D-pairs are different. A string is surprising if it is D-unique for every possible distance D.

Consider the string ZGBG. Its 0-pairs are ZG, GB, and BG. Since these three pairs are all different, ZGBG is 0-unique. Similarly, the 1-pairs of ZGBG are ZB and GG, and since these two pairs are different, ZGBG is 1-unique. Finally, the only 2-pair of ZGBG is ZG, so ZGBG is 2-unique. Thus ZGBG is surprising. (Note that the fact that ZG is both a 0-pair and a 2-pair of ZGBG is irrelevant, because 0 and 2 are different distances.)

Acknowledgement: This problem is inspired by the "Puzzling Adventures" column in the December 2003 issue of Scientific American.

Input

The input consists of one or more nonempty strings of at most 79 uppercase letters, each string on a line by itself, followed by a line containing only an asterisk that signals the end of the input.

Output

For each string of letters, output whether or not it is surprising using the exact output format shown below.

Sample Input

ZGBG
X
EE
AAB
AABA
AABB
BCBABCC
*

Sample Output

ZGBG is surprising.
X is surprising.
EE is surprising.
AAB is surprising.
AABA is surprising.
AABB is NOT surprising.
BCBABCC is NOT surprising.

Source


題意:給出一個一個字符串,找距離爲D的兩個字母組成一個字符串,看有沒有重複的

比如 ZGBG

當 D=0 時,有ZG , GB , BG 都不相同

當 D=1 時,有ZB , GG  也不相同

當 D=2 時,有ZG 只有一個不想同

所以是 Surprising Strings


分析:暴力找,set


爛代碼

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <set>
#include <string>
#include <iostream>
using namespace std;
int main()
{
    char s[100];
    int n,m,i,j,l;
    while(~scanf("%s",s))
    {
        if(strcmp(s,"*")==0)
        {
            break;
        }
        l=strlen(s);
        if(l<=2)
        {
            printf("%s is surprising.\n",s);
            continue;
        }
        set<string>q;
        set<string>::iterator it;
        int flag=0;
        for(i=1;i<=l-1;i++)
        {
            q.clear();
            string x;
           // printf("%d\n",i);
            for(j=0;j<l;j++)
            {
                x.clear();
                if(j+i<l)
                {
                    x+=s[j];
                    x+=s[j+i];
                    x+='\0';
                }
                //cout<<x<<endl;
                if(x.size()!=0)
                {
                    if(q.find(x)==q.end())
                    {
                        q.insert(x);
                    }
                    else
                    {
                        flag=1;
                        break;
                    }
                }

//                for(it=q.begin();it!=q.end();it++)
//                {
//                    cout<<*it<<endl;
//                }
            }
            if(flag)
            {
                break;
            }
        }
        if(flag)
        {
            printf("%s is NOT surprising.\n",s);
        }
        else
        {
            printf("%s is surprising.\n",s);
        }

    }

    return 0;
}







發佈了74 篇原創文章 · 獲贊 48 · 訪問量 2萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章