POJ Balanced Lineup 3264

                                                             

Balanced Lineup
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 48372   Accepted: 22684
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N andQ.
Lines 2..N+1: Line i+1 contains a single integer that is the height of cowi
Lines N+2..N+Q+1: Two integers A and B (1 ≤ABN), representing the range of cows from A toB inclusive.

Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

Source


題意:給定區間,求區間最大最小值的差

分析:可以用線段樹做,沒有更新

   也可以用RMQ,代碼也不多

//線段樹

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <stdlib.h>
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define maxx 51000
#define inf 1123456
long long Max[maxx<<2];
long long Min[maxx<<2];
void gengxin(int rt)
{
    Max[rt]=max(Max[rt<<1],Max[rt<<1|1]);
    Min[rt]=min(Min[rt<<1],Min[rt<<1|1]);
}
void build(int l,int r,int rt)
{
    if(l==r)
    {
        scanf("%lld",&Max[rt]);
        Min[rt]=Max[rt];
        
        return ;
    }
    int m=(l+r)>>1;
    build(lson);
    build(rson);
    gengxin(rt);
}
long long querymax(int x,int y,int l,int r,int rt)
{
    if(x<=l&&r<=y)
    {
        return Max[rt];
       // printf("%lld\n",Max[rt]);
    }

    int m=(l+r)>>1;
    long long ret=-inf;
    if(x<=m)
         ret=max(ret,querymax(x,y,lson));
    if(m<y)
         ret=max(ret,querymax(x,y,rson));

    return ret;
}
long long querymin(int x,int y,int l,int r,int rt)
{
    if(x<=l&&r<=y)
    {
        return Min[rt];
    }
    int m=(l+r)>>1;
    long long ret=inf;
    if(x<=m)
         ret=min(ret,querymin(x,y,lson));
    if(m<y)
         ret=min(ret,querymin(x,y,rson));
    return ret;
}
int main()
{
    int n,m,i,j,x,y;
    while(~scanf("%d%d",&n,&m))
    {
    build(1,n,1);
    while(m--)
    {
        scanf("%d%d",&x,&y);
        long long l=querymax(x,y,1,n,1);
        long long s=querymin(x,y,1,n,1);;
        printf("%lld\n",l-s);

    }
    }
    return 0;
}

//RMQ

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <math.h>
using namespace std;
//F[i][j]代表【i,i+(1<<j)+1】區間中的最值
int Fmax[51234][20];
int Fmin[51234][20];

void f(int n)
{
    int i,j;
    for(j=1;j!=20;j++)
    {
        for(i=1;i<=n;i++)
        {
            if(i+(1<<j)-1<=n)
            {
                //所以是j-1,前面的要加上
                Fmax[i][j]=max(Fmax[i][j-1],Fmax[i+(1<<(j-1))][j-1]);
                Fmin[i][j]=min(Fmin[i][j-1],Fmin[i+(1<<(j-1))][j-1]);
            }

        }
    }
}

int main()
{
    int n,m,i,j;
    int a,b;
    scanf("%d%d",&n,&m);
    for(i=1;i<=n;i++)
    {
        scanf("%d",&Fmax[i][0]);
        Fmin[i][0]=Fmax[i][0];
    }
    f(n);
    while(m--)
    {
        scanf("%d%d",&a,&b);
        int k;
        k=int(log(b-a+1.0)/log(2.0));
        int maxx=max(Fmax[a][k],Fmax[b-(1<<k)+1][k]);
        int minn=min(Fmin[a][k],Fmin[b-(1<<k)+1][k]);
        printf("%d\n",maxx-minn);
    }
    return 0;
}





發佈了74 篇原創文章 · 獲贊 48 · 訪問量 2萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章