POJ Buy Tickets 2828(線段樹)

Buy Tickets
Time Limit: 4000MS   Memory Limit: 65536K
Total Submissions: 18841   Accepted: 9352

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ iN). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

Source


題意:有一個空隊列,給出按時間順序插隊的序列,問最後這個隊列裏的人按什麼順序排列的

分析:一開始用鏈表插入,結果超時,看網上說是用線段樹,看了好大會

倒着來插,最後的順序一定是確定的,用sum[ ],來確定有多少空位,data[ ],插入數據,如果這一個比上一個序號小,就插到這個數前面,如果比這個大,就插到這個序號減去前一個數前面的空格數的位置

看代碼,時間好長

#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define maxx 200100
int sum[maxx<<2],data[maxx];
void up(int rt)
{
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void build(int l,int r,int rt)
{
    if(l==r)
    {
        sum[rt]=1;
        return ;
    }
    int m=(l+r)>>1;
    build(lson);
    build(rson);
    up(rt);
}
void gengxin(int x,int y,int l,int r,int rt)
{
    if(l==r)
    {
        data[l]=y;
        sum[rt]=0;
        return ;
    }
    int m=(l+r)>>1;
    if(x<sum[rt<<1])
    {
        gengxin(x,y,lson);
    }
    else
    {
        gengxin(x-sum[rt<<1],y,rson);
    }
    up(rt);
}
int main()
{
    int n,m,i,j;
    int x[maxx],y[maxx];
    while(~scanf("%d",&n))
    {
        build(1,n,1);
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&x[i],&y[i]);
        }
        for(j=n-1;j>=0;j--)
        {
            gengxin(x[j],y[j],1,n,1);
        }
        for(i=1;i<=n-1;i++)
        {
            printf("%d ",data[i]);
        }
        printf("%d\n",data[n]);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章