【poj 2068】Nim

Nim
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 1429 Accepted: 809

Description
Let's play a traditional game Nim. You and I are seated across a table and we have a hundred stones on the table (we know the number of stones exactly). We play in turn and at each turn, you or I can remove on to four stones from the heap. You play first and the one who removed the last stone loses.
In this game, you have a winning strategy. To see this, you first remove four stones and leave 96 stones. No matter how I play, I will end up with leaving 92 - 95 stones. Then you will in turn leave 91 stones for me (verify this is always possible). This way, you can always leave 5k+1 stones for me and finally I get the last stone, sigh. If we initially had 101 stones, on the other hand, I have a winning strategy and you are doomed to lose.

Let's generalize the game a little bit. First, let's make it a team game. Each team has n players and the 2n players are seated around the table, with each player having opponents at both sides. Turn around the table so the two teams play alternately. Second, let's vary the maximum number of stones each player can take. That is, each player has his/her own maximum number of stones he/she can take at each turn (The minimum is always one). So the game is asymmetric and may even be unfair.

In general, when played between two teams of experts, the outcome of a game is completely determined by the initial number of stones and the maximum number of stones each player can take at each turn. In other words, either team has a winning strategy.

You are the head-coach of a team. In each game, the umpire shows both teams the initial number of stones and the maximum number of stones each player can take at each turn. Your team plays first. Your job is, given those numbers, to instantaneously judge whether your team has a winning strategy.

Incidentally, there is a rumor that Captain Future and her officers of Hakodate-maru love this game, and they are killing their time playing it during their missions. You wonder where the stones are? Well, they do not have stones but do have plenty of balls in the fuel containers!

Input
The input is a sequence of lines, followed by the last line containing a zero. Each line except the last is a sequence of integers and has the following format.

n S M1 M2 . . . M2n

where n is the number of players in a team, S the initial number of stones, and Mi the maximum number of stones ith player can take. 1st, 3rd, 5th, ... players are your team's players and 2nd, 4th, 6th, ... the opponents. Numbers are separated by a single space character. You may assume 1 <= n <= 10, 1 <= Mi <= 16, and 1 <= S < 2^13.

Output
The output should consist of lines each containing either a one, meaning your team has a winning strategy, or a zero otherwise.

Sample Input

1 101 4 4
1 100 4 4
3 97 8 7 6 5 4 3
0

Sample Output

0
1

1

題意:分兩隊每隊有n個人,一共有S顆石子,接下來的2n個數代表每個人一次能拿的石子的最少個數,每個隊的人交叉排排坐。

           問,先拿的隊伍勝敗的狀態。

思路:用數組dp[i][j]存此時第i個人拿的時候還剩j個石子的情況,必敗態爲0,必勝態爲1.

          dp[i][0]都爲0;保證符合題目要求的情況下的當前的後繼狀態爲必敗態的時候,那麼當前爲必勝態。

code:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
int dp[25][8200],a[25];
int n,S;
int solve(int idx,int rem)
{
    if(dp[idx][rem]!=-1)
        return dp[idx][rem];
    if(rem==0)
        return dp[idx][rem]=1;
    dp[idx][rem]=0;
    for(int i=1;i<=a[idx]&&i<=rem;i++)
        if(!solve((idx+1)%(2*n),rem-i))
            dp[idx][rem]=1;
    return dp[idx][rem];
}
int main()
{
    while(scanf("%d%d",&n,&S)!=EOF&&n)
    {
        for(int i=0;i<2*n;i++)
            scanf("%d",&a[i]);
        memset(dp,-1,sizeof(dp));
        printf("%d\n",solve(0,S));
    }
    return 0;
}


發佈了68 篇原創文章 · 獲贊 9 · 訪問量 4萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章