Rescue The Princess(山東省第四屆ACM大學生程序設計競賽 )

Problem Description

    Several days ago, a beast caught a beautiful princess and the princess was put in prison. To rescue the princess, a prince who wanted to marry the princess set out immediately. Yet, the beast set a maze. Only if the prince find out the maze’s exit can he save the princess.

    Now, here comes the problem. The maze is a dimensional plane. The beast is smart, and he hidden the princess snugly. He marked two coordinates of an equilateral triangle in the maze. The two marked coordinates are A(x1,y1) and B(x2,y2). The third coordinate C(x3,y3) is the maze’s exit. If the prince can find out the exit, he can save the princess. After the prince comes into the maze, he finds out the A(x1,y1) and B(x2,y2), but he doesn’t know where the C(x3,y3) is. The prince need your help. Can you calculate the C(x3,y3) and tell him?

Input

    The first line is an integer T(1 <= T <= 100) which is the number of test cases. T test cases follow. Each test case contains two coordinates A(x1,y1) and B(x2,y2), described by four floating-point numbers x1, y1, x2, y2 ( |x1|, |y1|, |x2|, |y2|<= 1000.0).
    Please notice that A(x1,y1) and B(x2,y2) and C(x3,y3) are in an anticlockwise direction from the equilateral triangle. And coordinates A(x1,y1) and B(x2,y2) are given by anticlockwise.

Output

    For each test case, you should output the coordinate of C(x3,y3), the result should be rounded to 2 decimal places in a line.

Example Input

4
-100.00 0.00 0.00 0.00
0.00 0.00 0.00 100.00
0.00 0.00 100.00 100.00
1.00 0.00 1.866 0.50

Example Output

(-50.00,86.60)
(-86.60,50.00)
(-36.60,136.60)
(1.00,1.00)

題意:等邊三角形,按逆時針順序給出a,b兩個點,讓你求c點;

思路:純數學問題;

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <math.h>
#include<cmath>
#include <algorithm>
#include <vector>
#include <map>
#include <string>
#include <stack>
#define LL long long
#define INF 0x7fffffff
#define MAX 200010
#define PI 3.1415926535897932
using namespace std;

int main()
{
    int T;
    scanf("%d",&T);
    double x1,y1,x2,y2;
    double x,y;
    while(T--)
    {
        scanf("%lf%lf%lf%lf",&x1,&y1,&x2,&y2);
        if(abs(x1-x2) ==0)
        {
            if(y1<y2)
                x = x1- (sqrt(3.0) * (abs(y2-y1)/2));
            if(y1>y2)
                x = x1+ (sqrt(3.0) * (abs(y2-y1)/2));
            y = (y1+y2)/2;
            printf("(%.2lf,%.2lf)\n",x,y);
        }
        else
        {
            double L = sqrt( (x1-x2)*(x1-x2) + (y1-y2)*(y1-y2));
            double r1 = atan2( (y2-y1),(x2-x1));//包含正負號
            double r2 = PI/3 + r1;
            x = cos(r2)*L + x1;
            y = sin(r2)*L + y1;
            printf("(%.2lf,%.2lf)\n",x,y);
        }
    }
    return 0;
}


發佈了77 篇原創文章 · 獲贊 11 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章