hash&Rabin-Karp字符串查找POJ 1200 Crazy Search

Crazy Search
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 26045 Accepted: 7278
Description
Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon will discover, you really need the help of a computer and a good algorithm to solve such a puzzle.
Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text.

As an example, consider N=3, NC=4 and the text “daababac”. The different substrings of size 3 that can be found in this text are: “daa”; “aab”; “aba”; “bab”; “bac”. Therefore, the answer should be 5.
Input
The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed 16 Millions.
Output
The program should output just an integer corresponding to the number of different substrings of size N found in the given text.
Sample Input
3 4
daababac
Sample Output
5
Hint
Huge input,scanf is recommended.


Source
Southwestern Europe 2002

Hash & Rabin-Karp字符串查找算法,具體介紹參考:
http://novoland.github.io/%E7%AE%97%E6%B3%95/2014/07/26/Hash%20&%20Rabin-Karp%E5%AD%97%E7%AC%A6%E4%B8%B2%E6%9F%A5%E6%89%BE%E7%AE%97%E6%B3%95.html

#include <stdio.h>
#include <fstream>
#include <string.h>
#include<iostream> 
using namespace std;
#define MAX 16000005
char s[MAX];
int ascii[256],hash[MAX], n,nc,len,ans,sum,tmp;
int main(){
    freopen("i.txt","r",stdin);
    while(scanf("%d%d%s",&n,&nc,s)!=EOF){   
       ans=0;
       memset(ascii,0,sizeof(ascii)),memset(hash,0,sizeof(hash));
       scanf("%s",s);
       len=strlen(s);
       for(int i=0,j=0; i<len; i++)  {
           if(!ascii[s[i]]) ascii[s[i]]=j++; //字母按出現順序編號
           if(j==nc) break;    
       }
       tmp=len-n+1;
       for(int i=0; i<tmp; i++)  { //計算子串的hash值                     
            sum=0;
            for(int j=0; j<n ; j++) {
            sum=sum*nc+ascii[s[i+j]];//秦九韶算法,也叫霍納算法
          }
          if(!hash[sum]){
              hash[sum]=1;
              ans++;
          }
       }
       cout<<ans<<endl; 
    }
    return 0;
}
發佈了77 篇原創文章 · 獲贊 22 · 訪問量 7萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章