Poj 2752

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

Step1. Connect the father's name and the mother's name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)
Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.
Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.
Sample Input

ababcababababcabab
aaaaa
Sample Output

2 4 9 18

1 2 3 4 5

題意:問前後綴相同的字符個數。注意本身也算

解析:直接看next數組即可,找規律,注意下標

#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
const int maxn=500000;
int next[maxn];
char str[maxn];
void getNext(char *s,int *next)
{
    next[0] = -1;
    int i,j;
	for (i=0,j=-1;s[i];){
		if (j==-1||s[i]==s[j]){
			i++; j++;
			next[i]=j;
		}
		else{
			j=next[j];
		}
	}


}
int main()
{
    while(scanf("%s",str)!=EOF&&str[0])
    {
        memset(next,0,sizeof(next));
        int len=strlen(str);
        getNext(str,next);
        int lens=1;
        int cn[maxn];
        int cnt=0;
        for(int i=len;i>=0;)
        {   if((next[i])!=-1&&next[i])
            //printf("%d %d\n",i,next[i]);
            cn[cnt++]=next[i];
           i=next[i];
        }
        for(int i=cnt-1;i>=0;i--)
        printf("%d ",cn[i]);
        printf("%d\n",len);

    }
    return 0;
}


發佈了65 篇原創文章 · 獲贊 1 · 訪問量 2萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章