Poj 2001 Shortest Prefixes

Description

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents.

In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo".

An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list that begins with "car".
Input

The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.
Output

The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.
Sample Input

carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate
Sample Output

carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=100009;
char str[maxn][52];
struct trie
{
    int next[32];
    int cnt;
    void init()
    {
        cnt=0;
        memset(next,0,sizeof(next));
    }
}tree[maxn];
int index;
void insert(char *s)
{
    int len=strlen(s);
    int p=0;
    for(int i=0;i<len;i++)
    {
        int x=s[i]-'a';
        if(tree[p].next[x]==0)
        {
            tree[index+1].init();
            tree[p].next[x]=++index;
        }
        tree[tree[p].next[x]].cnt++;
        p=tree[p].next[x];
    }
}
void find(char *s)
{
    int len=strlen(s);
    int p=0;
    for(int i=0;i<len;i++)
    {
        int x=s[i]-'a';
        if(tree[p].cnt==1)
         {return;
         }
         else
         {
             printf("%c",s[i]);

         }
         p=tree[p].next[x];
    }
}
int main()
{
    tree[0].init();
    int index1=0;
        index=0;
    while(scanf("%s",str[index1])!=EOF)
    {
        insert(str[index1]);
        index1++;
    }
         /*int len=strlen(str[0]);
         int p=0;
         for(int i=0;i<len;i++)
         {
             int x=(int)(str[0][i]-'a');
             printf("%d %d\n",tree[p].next[x],tree[p].cnt);
              p=tree[p].next[x];
         }*/

    for(int i=0;i<index1;i++)
    {   printf("%s ",str[i]);
        find(str[i]);
        printf("\n");
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章