POJ - 3356 AGTC 區間dp

Description

Let x and y be two strings over some finite alphabet A. We would like to transform x into y allowing only operations given below:

Deletion: a letter in x is missing in y at a corresponding position.
Insertion: a letter in y is missing in x at a corresponding position.
Change: letters at corresponding positions are distinct
Certainly, we would like to minimize the number of all possible operations.

Illustration
A G T A A G T * A G G C

| | | | | | |

A G T * C * T G A C G C
Deletion: * in the bottom line
Insertion: * in the top line
Change: when the letters at the top and bottom are distinct
This tells us that to transform x = AGTCTGACGC into y = AGTAAGTAGGC we would be required to perform 5 operations (2 changes, 2 deletions and 1 insertion). If we want to minimize the number operations, we should do it like

A G T A A G T A G G C

| | | | | | |

A G T C T G * A C G C
and 4 moves would be required (3 changes and 1 deletion).

In this problem we would always consider strings x and y to be fixed, such that the number of letters in x is m and the number of letters in y is n where n ≥ m.

Assign 1 as the cost of an operation performed. Otherwise, assign 0 if there is no operation performed.

Write a program that would minimize the number of possible operations to transform any string x into a string y.

Input

The input consists of the strings x and y prefixed by their respective lengths, which are within 1000.

Output

An integer representing the minimum number of possible operations to transform any string x into a string y.

Sample Input

10 AGTCTGACGC
11 AGTAAGTAGGC

Sample Output

4

題意:
給出字符串s1。s2。
求出將s1通過下列三種操作:
1.插入一個字符
2.刪除一個字符
3.改變一個字符
變換成字符s2所需要的最小操作次數。

題解:
定義dp[i][j]表示將s1的前i個和s2的前j個進行匹配所需的最小值。
可以將s1的第i個刪掉,即dp[i-1][j]+1
或者將s2的第j個刪掉,即dp[i][j-1]+1
或者將s1的第i個和s2的第j個進行匹配,根據它們是否相同來判斷dp[i-1][j-1]是否+1
【依舊只是對拍了而已。
update:10.29 代碼沒問題,但是poj很坑的是多組數據。。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int N = 1000 + 10;

int n1,n2;
int dp[N][N];
char s1[N],s2[N];

int main(){
    while(~scanf("%d%s",&n1,s1+1)){
        scanf("%d%s",&n2,s2+1);
        memset(dp,63,sizeof(dp));
        for(int i=0;i<=max(n1,n2);++i) dp[i][0]=dp[0][i]=i;
        for(int i=1;i<=n1;++i){
            for(int j=1;j<=n2;++j){
                dp[i][j]=min(dp[i][j-1]+1,dp[i-1][j]+1);
                dp[i][j]=min(dp[i][j],dp[i-1][j-1]+(s1[i]!=s2[j]));
            }
        }
        printf("%d\n",dp[n1][n2]);
    }
    return 0;
}
發佈了178 篇原創文章 · 獲贊 5 · 訪問量 2萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章