POJ - 1651 Multiplication Puzzle 區間dp

Description

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row.

The goal is to take cards in such order as to minimize the total number of scored points.

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5

Sample Output

3650

題意:
給你一組數字,第一個和最後一個數字不可以取出去,其它任意取出去,當你要取出一個數字時,它有一個代價,這個代價就是與它相鄰的兩個數的乘積,求除了首位兩位數字,把其他數字都取出來,它們的代價之和的最小值。

題解:
定義dp[i][j]表示將i到j合併的最小值。(最後的答案就在dp[2][n-1]中) ,然後轉移的時候枚舉k,表示在[i,j]這段區間中最後取k,則代價就是dp[i][k-1]+dp[k+1][j]+a[i-1]*a[k]*a[j+1]
//因爲此時k這個數的兩邊就是i-1和j+1了,這也是爲什麼邊界不是1和n,而是2和n-1。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int N = 100 + 10;

int n;
int a[N];
int dp[N][N];

int main(){
    scanf("%d",&n);
    for(int i=1;i<=n;++i) scanf("%d",&a[i]);
    memset(dp,63,sizeof(dp));
    for(int i=1;i<=n;++i) dp[i][i]=a[i-1]*a[i]*a[i+1],dp[i][i-1]=0;
    for(int len=2;len<=n;++len){
        for(int i=2;i+len-1<n;++i){
            int j=i+len-1;
            for(int k=i;k<=j;++k){
                dp[i][j]=min(dp[i][j],dp[i][k-1]+dp[k+1][j]+a[i-1]*a[k]*a[j+1]);
            }
        }
    }
    if(n<=2) printf("0");
    else printf("%d\n",dp[2][n-1]);
    return 0;
}
發佈了178 篇原創文章 · 獲贊 5 · 訪問量 2萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章