hdu 1863 hdoj 1863

暢通工程

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7784    Accepted Submission(s): 2969


Problem Description
省政府“暢通工程”的目標是使全省任何兩個村莊間都可以實現公路交通(但不一定有直接的公路相連,只要能間接通過公路可達即可)。經過調查評估,得到的統計表中列出了有可能建設公路的若干條道路的成本。現請你編寫程序,計算出全省暢通需要的最低成本。
 

Input
測試輸入包含若干測試用例。每個測試用例的第1行給出評估的道路條數 N、村莊數目M ( < 100 );隨後的 N
行對應村莊間道路的成本,每行給出一對正整數,分別是兩個村莊的編號,以及此兩村莊間道路的成本(也是正整數)。爲簡單起見,村莊從1到M編號。當N爲0時,全部輸入結束,相應的結果不要輸出。
 

Output
對每個測試用例,在1行裏輸出全省暢通需要的最低成本。若統計數據不足以保證暢通,則輸出“?”。
 

Sample Input
3 3 1 2 1 1 3 2 2 3 4 1 3 2 3 2 0 100
 

Sample Output
3 ?
 
#include<iostream>
#include<stdio.h>
#include<cstdlib>
using namespace std;
typedef struct country{
    int x;
    int y;
    int weight;
}country;

int father[100];
int n,m;

int compare(const void *a,const void *b){
    return (*(country*)a).weight-(*(country*)b).weight;
}

void init(){
    for(int i=1;i<100;i++){
        father[i]=i;
    }
}

int find(int i){
    if(i!=father[i]){
        find(father[i]);
    }
    return father[i];
}

void unionfather(int a,int b){
    int x=find(a),y=find(b);
    if(x<y){
        father[y]=x;
    }
    else{
        father[x]=y;
    }
}

int lestcost(country *cou){
    int cost=0,count=0;
    init();
    for(int i=0;i<n;i++){
        if(find(cou[i].x)!=find(cou[i].y)){
            unionfather(cou[i].x,cou[i].y);
            cost+=cou[i].weight;
            count++;
        }
    }
    if(count!=m-1) cost=-1;
    return cost;
}

int main(){
    country cou[10000];
    int cost;
    while(scanf("%d%d",&n,&m),n!=0){
        for(int i=0;i<n;i++){
            scanf("%d%d%d",&cou[i].x,&cou[i].y,&cou[i].weight);
        }
        qsort(cou,n,sizeof(country),compare);
        cost=lestcost(cou);
        if(cost==-1) printf("?\n");
        else printf("%d\n",cost);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章