Minimum Transport Cost(ZOJ - 1456)

題目:

These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:
The cost of the transportation on the path between these cities, and
a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.
You must write a program to find the route which has the minimum cost.

Input

First is N, number of cities. N = 0 indicates the end of input.
The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 … a1N
a21 a22 … a2N

aN1 aN2 … aNN
b1 b2 … bN

c d
e f

g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, …, and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:

Output

From c to d :
Path: c–>c1–>…–>ck–>d
Total cost : …

From e to f :
Path: e–>e1–>…–>ek–>f
Total cost : …

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

Sample Input

5
0 3 22 -1 4
3 0 5 -1 -1
22 5 0 9 20
-1 -1 9 0 4
4 -1 20 4 0
5 17 8 3 1
1 3
3 5
2 4
-1 -1
0

Sample Output

From 1 to 3 :
Path: 1-->5-->4-->3
Total cost : 21

From 3 to 5 :
Path: 3-->4-->5
Total cost : 16

From 2 to 4 :
Path: 2-->1-->5-->4
Total cost : 17

思路:這是最短路徑的問題,不過要求出所走的路徑是什麼?
我用的是Floyd算法,因爲除了所走的初末位置其他點都需要稅款,所以此時的最短經費就是所要的運費和稅款。然後就是路徑了,首先用二維數組b[][]去存儲一點到另一個點的路徑,也就是噹噹前的e[i][j]需要更新時,從一點去另一個點也需要重新規劃路徑。
注意:如果有更多的最小路徑,則輸出點最小的路徑,也就是當e[i][j]不需要更新時,該點與另一個點取較小的。

程序代碼:

#include<stdio.h>
int e[2000][2000],n,a[5000],b[2000][2000];
int inf=999999999;
void floyd()
{
	int k,i,j,ma;
	for(i=1;i<=n;i++)
		for(j=1;j<=n;j++)
			b[i][j]=j;	
	for(k=1;k<=n;k++)
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
			{
				if(e[i][k]<inf&&e[k][j]<inf)
				{
					ma=e[i][k]+e[k][j]+a[k];
					if(e[i][j]>ma)
					{
						e[i][j]=ma;
						b[i][j]=b[i][k];
					}
					else if(e[i][j]==ma)
					{
						if(b[i][j]>b[i][k])
							b[i][j]=b[i][k];
					}
				}
			}
/*	for(i=1;i<=n;i++)
		for(j=1;j<=n;j++)
			printf("*%d ",b[1][j]);
	printf("\n");*/
}
int main()
{
	int i,j,w,x,y,t1,t2;
	while(scanf("%d",&n),n!=0)
	{
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
				{
					scanf("%d",&w);
					if(w==-1)
						w=inf;
					e[i][j]=w;
				}
		for(i=1;i<=n;i++)
			scanf("%d",&a[i]);
		floyd();
		while(scanf("%d%d",&x,&y)!=EOF)
		{
			if(x==-1&&y==-1)
				break;
			t1=x;
			t2=y;
			printf("From %d to %d :\n",x,y);
			printf("Path: %d",x);
			while(x!=y)
			{
				printf("-->%d",b[x][y]);
				x=b[x][y];
			}
			printf("\n");
			printf("Total cost : %d\n",e[t1][t2]);
			printf("\n");
		}	
	}
	return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章