hdu 2451 Simple Addition Expression(數位dp)

Simple Addition Expression

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1553    Accepted Submission(s): 595


Problem Description
A luxury yacht with 100 passengers on board is sailing on the sea in the twilight. The yacht is ablaze with lights and there comes out laughers and singing from the hall where an evening party is in full swing. People are singing, dancing and enjoying themselves.

The yacht is equipped with the most advanced navigation and driving system which can all be manipulated by a computer. When the captain notices that there is only gentle breeze and the sea waves are not high, he starts the autopilot. The yacht sails forward smoothly, ploughs the waves. When it’s completely dark, the passengers start to feel a little funny for sudden forward rushes or sudden decelerations or slight swings. The captain immediately walks to the driving platform and switches the autopilot to human manipulation. The yacht returns back to normal and the party restarts. Laughers come back, too.

The captain summons the engineer on board to do a thorough check of the navigation system. It turns out that only the computer is out of order, but the exact failure is still unclear. There is a computer scientist among the passengers who is also invited to the cab to give a hand. He first inputs several groups of data to test the computer. When he inputs 1+2+3, the computer outputs 6, which is exactly right. But when he inputs 4+5+6, the computer outputs 5, which is wrong. Then he inputs 12+13+14, and gets 39, another right answer, while he inputs 14+15+16, and gets 35, another wrong answer. After the test, the computer scientist says smilingly: “the failure is clear now. The computer's adder can not carry." After excluding the failure, the captain restarts the autopilot and the yacht returns back to normal, sailing smoothly on the sea.

The captain and the engineer invite the computer scientist to sit down and have a talk. The computer scientist tells a story as following:

A former mathematician defined a kind of simple addition expression. 
If there is an expression (i) + (i+1) + (i+2), i>=0, when carried out additive operations, no position has a carry, it is called simple addition expression.

For instance, when i equals 0, 0+1+2 is a simple addition expression, meanwhile when i equals 11, 11+12+13 is a simple addition expression, too. Because of that no position has a carry.

However, when i equals 3, 3+4+5 is not a simple addition expression, that is because 3+4+5 equals 12, there is a carried number from unit digit to tens digit. In the same way, when i equals 13, 13+14+15 is not a simple addition expression, either. However, when i equals 112, 112+113+114 is a simple addition expression. Because 112+113+114 equals 339, there is no carry in the process of adding.

when the students have got the definition of simple addition expression, the mathematician puts forward a new question: for a positive integer n, how many simple addition expressions exist when i<n. In addition, i is the first number of a simple addition expression.

when the value of n is large enough, the problem needs to be solved by means of computer.

 

Input
There are several test cases, each case takes up a line, there is an integer n (n<10^10).

 

Output
Output the number of all simple addition expressions when i<n.

 

Sample Input
1 2 3 4 10 11
 

Sample Output
1 2 3 3 3 4
 

Source
 


題意:讓你求出  i<n 滿足i + (i+1) + (i+2)相加不用進位的 i 的數量。

題解:數位dp. 個位數不能超過2,若超過2,有3+4+5=12;其他位不能超過3. 一開始傻逼了,(考慮999+1000+1001,以爲是合法的。。)

#include<cstring>
#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstdlib>
#define ll long long

using namespace std;

ll n;

ll dp[20];
int num[20];
ll a,b;

ll dfs(int i,bool e) {
    if(!e&&dp[i]!=-1)return dp[i];
    ll res=0;
    int u=e?num[i]:9;
    for(int d=0; d<=u&&d<=3; d++) {
        if(i==0) {
            if(d<3)res++;
        } else {
            res+=dfs(i-1,e&&d==u);
        }
    }
    return e?res:dp[i]=res;
}

ll solve(ll x) {
    if(x==0)return 1;
    if(x<0)return 0;
    int len=0;
    ll k=x;
    while(k) {
        num[len++]=k%10;
        k/=10;
    }
    num[len]=0;
    return dfs(len-1,1);
}

int main() {
    //freopen("test.in","r",stdin);
    memset(dp,-1,sizeof dp);
    while(~scanf("%I64d",&n)) {
        printf("%I64d\n",solve(n-1));
    }
    return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章