PAT甲 2019年秋季考试 7-1 Forever (20 分) DFS+剪枝

7-1 Forever (20分)

“Forever number” is a positive integer A with K digits, satisfying the following constrains:

the sum of all the digits of A is m;
the sum of all the digits of A+1 is n; and
the greatest common divisor of m and n is a prime number which is greater than 2.
Now you are supposed to find these forever numbers.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤5). Then N lines follow, each gives a pair of K (3<K<10) and m (1<m<90), of which the meanings are given in the problem description.

Output Specification:

For each pair of K and m, first print in a line Case X, where X is the case index (starts from 1). Then print n and A in the following line. The numbers must be separated by a space. If the solution is not unique, output in the ascending order of n. If still not unique, output in the ascending order of A. If there is no solution, output No Solution.

Sample Input:

2
6 45
7 80

Sample Output:

Case 1
10 189999
10 279999
10 369999
10 459999
10 549999
10 639999
10 729999
10 819999
10 909999
Case 2
No Solution

思路:

枚举每一位,考虑每一位取值后位数和与m的关系,
注定取不到m的便剪枝:
1. 若当前位数和为sum,当前位取i,剩余rest_K - 1位全取9仍然达不到m,则剪枝 。
即 if( sum + i + (rest_K-1) * 9 < m) return ;
2. 若当前位数和位为sum,当前位取i,已经超过m,则剪枝
即 if ( sum + i > m) return ;
并需要注意首位只能取1 ~ 9,剩下k-1位可取0 ~ 9 。
在这里插入图片描述

Case:

#include<cstdio> 
#include<algorithm> 
#include<vector> 
using namespace std;
struct node{
	int n,A;
};
int n,m,N,k;
vector<node> ans;
bool cmp(node a,node b){
	if(a.n != b.n) return a.n < b.n;
	else return a.A < b.A;
}
bool isPrime(int x){
	if(x <= 2) return false;
	for(int i = 2; i * i<= x; i++)
		if(x % i == 0) return false;
	return true;
}
int gcd(int a,int b){
	return b == 0 ? a : gcd(b,a%b);
}
int digit_sum(int A){
	int sum = 0;
	while(A){
		sum += A%10;
		A/=10;
	}
	return sum;
}
void DFS(int A,int sum,int rest_K){
	if(rest_K == 0){
		if(sum == m){
			int n = digit_sum(A+1);
			if(isPrime(gcd(m,n)))
				ans.push_back({n,A});
		}
	}
	else if(rest_K > 0){
		for(int i = 0; i <= 9; i++){
			if(sum + i + (rest_K-1)*9 >= m && sum + i <= m)
				DFS(A*10 + i,sum+i,rest_K-1);
		}
	}
}
int main(){
	scanf("%d",&N);
	for(int x = 1; x <= N; x++){
		ans.clear();
		printf("Case %d\n",x);
		scanf("%d%d",&k,&m);
		for(int i = 1; i <= 9; i++)
			DFS(i,i,k-1);
		if(ans.empty()){
			printf("No Solution\n");
			continue;
		}
		sort(ans.begin(),ans.end(),cmp);
		for(int i = 0; i < ans.size(); i++){
			printf("%d %d\n",ans[i].n,ans[i].A);
		}
	} 
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章