編程入門 A+B CSU - 1000 1001 1002

CSU - 1000

Description

Your task is to Calculate a + b.

Input

Input contains multiple test cases. Each test case consists of a pair of integers a and b ( 0 <= ab <= 20 ), separated by a space, one pair of integers per line.

Output

For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

Sample Input

1 1

Sample Output

2

代碼:

#include<iostream>
using namespace std;
////
int main()
{
	int a,b;
	while(cin>>a>>b)
	{
		cout<<a+b<<endl;
	}
	return 0;
}


    CSU - 1001

Description

Your task is to Calculate a + b.

Input

There are multiple test cases. Each test case contains only one line. Each line consists of a pair of real number a and b(0<=a,b<=1000000), separated by a space.

Output

For each case, output the answer in one line rounded to 4 digits after the decimal point.

Sample Input

1 5
10 20
0.1 1.5

Sample Output

6.0000
30.0000
1.6000

代碼:

#include<iostream>
#include <iomanip>
using namespace std;
//
int main()
{
	double a,b;
	while(cin>>a>>b)
	{
		cout<<fixed<<setprecision(4)<<a+b<<endl;
	}
	return 0;
}


    CSU - 1002

Description

Your task is to Calculate a + b.

Input

There are multiple test cases. Each test case contains only one line. Each line consists of a pair of integers a and b ( 1 <= ab<=1016 ) , separated by a space. Input is followed by a single line with a = 0, b = 0, which should not be processed.

Output

For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

Sample Input

1 5
10 20
10000000000000000 10000000000000000
0 0

Sample Output

6
30
20000000000000000

代碼:
#include<iostream>
using namespace std;
//
int main()
{
	long long a,b;
	while(cin>>a>>b)
	{
		if(a==0&&b==0)
		break;
		cout<<a+b<<endl;
	}
	return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章