二分法應用 HDU - 2899 Strange fuction

Strange fuction

Problem Description
Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10) 
Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100. 
Sample Input
2
100
200
Sample Output
-74.4291
-178.8534

代碼:

#include<stdio.h> 
double Y;
double y(double x){
	return (42*x*x*x*x*x*x+48*x*x*x*x*x+21*x*x+10*x);
}
double f(double x){
	return (6*x*x*x*x*x*x*x+8*x*x*x*x*x*x+7*x*x*x+5*x*x)-x*Y;
}

int main(){
	int T;
	//double Y;
	scanf("%d",&T);
	double loc;
	
	while(T--){
		double low=0,high=100;
		scanf("%lf",&Y);
		
		while(low<high){
			loc=(low+high)/2;
			
			if((high-low)<0.000000001){
				printf("%.4lf\n",f(loc));
				break;
			}else if(y(loc)>=Y){
				high=loc;
			}else if(y(loc)<=Y){
				low=loc;
			}
		}
	}
	
	return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章