動態規劃之快速冪 CSU - 1198 Staginner the Caster

Description

Staginner , a wise coder , became a legendary soul after centuries later somehow . So one day he was summoned by a sorcerer , Gestapolur . The sorcerer said : I'm facing a hard problem and it's so obscure that even make me wanna going to die . So I summoned you for help.

The problem was described as following:

There are N(1<=N<=231-1) magic grails , each grail could have none or several magic properties . And there are K(1<=K<=N) magic properties .We supposed that all grails have property i are belong to set S_i . And because some mysterious reason , S1 ∩ S2 ∩ ... ∩ Smust be empty. So how many grail-arrange scheme could satisfy these condition ?

Input

The input contains multiple cases, each case have 2 integers in one line represent n and k(1 <= k <= n <= 231-1), proceed to the end of the file.

Output

Output the total number mod 1000000007.

Sample Input

1 1
2 2

Sample Output

1
9

思路:根據題意符合條件的情況有:種。

          但是N非常非常的大,所以先求C=,然後求C的平方就可以了。

代碼:

#include<iostream>
using namespace std;
#define MO 1000000007
int fab(int a,int b) //a^b%1000000007
{
	if (b==1) return a;
	
	long long c = fab(a, b / 2);//fab(a, b / 2)*fab(a, b / 2) % MO
	c = c*c%MO;
	c = (b % 2 == 1) ? c*a%MO : c;
	return c;
	
}
int main()
{
	int n, k;
	while (cin >> n >> k)
	{
		int kk = fab(2, k) - 1;
		cout << fab(kk, n) << endl;
	}
	return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章