poj-1426 Find The Multiple

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

        題意:給你一個數,找到它的僅由0和1組成的倍數。該題special judge。

        思路:用的類似BFS的方法來枚舉所有由0和1組成的數,知道找到n的倍數結束循環。如果超時還可以把200個數的表打出來。注意,用C++提交會超時。

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <queue>
#define INF 0x3f3f3f3f

using namespace std;

int n;
long long int  BFS()
{
    queue<long long>Q;
    Q.push(1);
    while(1)
    {
        long long x=Q.front();
        if(x%n==0) return x;
        Q.pop();
        Q.push(x*10+1);
        Q.push(x*10);
    }
}
int main()
{
    while(scanf("%d",&n),n)
    {
        printf("%lld\n",BFS());
    }
    return 0;
}

打表

#include <iostream>
#include<cstring>
using namespace std;
char  s[220][30]={"0","1","10","111","100","10","1110","1001","1000","111111111","10","11","11100","1001","10010","1110","10000",
"11101","1111111110","11001","100","10101","110","110101","111000","100","10010","1101111111","100100","1101101","1110","111011",
"100000","111111","111010","10010","11111111100","111","110010","10101","1000","11111","101010","1101101","1100","1111111110","1101010",
"10011","1110000","1100001","100","100011","100100","100011","11011111110","110","1001000","11001","11011010","11011111","11100",
"100101","1110110","1111011111","1000000","10010","1111110","1101011","1110100","10000101","10010","10011","111111111000","10001",
"1110","11100","1100100","1001","101010","10010011","10000","1111111101","111110","101011","1010100","111010","11011010","11010111",
"11000","11010101","1111111110","1001","11010100","10000011","100110","110010","11100000","11100001","11000010","111111111111111111",
"100","101","1000110","11100001","1001000","101010","1000110","100010011","110111111100","1001010111","110","111","10010000","1011011",
"110010","1101010","110110100","10101111111","110111110","100111011","111000","11011","1001010","10001100111","11101100","1000",
"11110111110","11010011","10000000","100100001","10010","101001","11111100","11101111","11010110","11011111110","11101000","10001",
"100001010","110110101","100100","10011","100110","1001","1111111110000","11011010","100010","1100001","11100","110111","11100","1110001",
"11001000","10111110111","10010","1110110","1010100","10101101011","100100110","100011","100000","11101111","11111111010","1010111",
"1111100","1111110","1010110","11111011","10101000","10111101","111010","1111011111","110110100","1011001101","110101110","100100",
"110000","100101111","110101010","11010111","11111111100","1001111","10010","100101","110101000","1110","100000110","1001011",
"1001100","1010111010111","110010","11101111","111000000","11001","111000010","101010","110000100","1101000101","1111111111111111110",
"111000011","1000","10010001","1010",};
int main()
{
    int n;
    while(cin>>n,n)
    {
        cout<<s[n]<<endl;
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章