HDOJ 1789 Doing Homework again

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11637    Accepted Submission(s): 6837


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
0 3 5
 
貪心算法,根據分值大小排序大的優先如果那天空閒就安排在那天,如果不空閒就向前推,如果前面也沒有那就扣分唄。剛接觸貪心,感覺理解的不透徹。摸不準怎樣纔是局部最優。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct WORK
{
	int t;
	int s;
}wok[1010];
int cmp(WORK a,WORK b)
{
	return a.s>b.s;
}
int main()
{
	int t,n,i,j,sum,a[1010],flag;
	scanf("%d",&t);
	while(t--)
	{	
		memset(a,0,sizeof(a));
		scanf("%d",&n);
		for(i=0;i<n;i++)
			scanf("%d",&wok[i].t);
		for(i=0;i<n;i++)
			scanf("%d",&wok[i].s);
		sort(wok,wok+n,cmp);
		/*for(i=0;i<n;i++)
			printf("%d ",wok[i].t);
			printf("\n");
		for(i=0;i<n;i++)
			printf("%d ",wok[i].s);*/
		sum=0;
		for(i=0;i<n;i++)
		{
			if(a[wok[i].t]==0)
			{
			a[wok[i].t]=1;
			continue;
			}
			if(a[wok[i].t]!=0)
			{	
				flag=0;
				for(j=wok[i].t-1;j>0;j--)
				{
					if(a[j]==0)
					{
					a[j]=1;
					flag=1;
					break;
					}
				}
				if(flag==0)
				sum+=wok[i].s;
			}
		}
		printf("%d\n",sum);
	}
	return 0;
}


 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章