HDOJ 4883 TIANKENG’s restaurant

TIANKENG’s restaurant

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 2604    Accepted Submission(s): 978


Problem Description
TIANKENG manages a restaurant after graduating from ZCMU, and tens of thousands of customers come to have meal because of its delicious dishes. Today n groups of customers come to enjoy their meal, and there are Xi persons in the ith group in sum. Assuming that each customer can own only one chair. Now we know the arriving time STi and departure time EDi of each group. Could you help TIANKENG calculate the minimum chairs he needs to prepare so that every customer can take a seat when arriving the restaurant?
 

Input
The first line contains a positive integer T(T<=100), standing for T test cases in all.

Each cases has a positive integer n(1<=n<=10000), which means n groups of customer. Then following n lines, each line there is a positive integer Xi(1<=Xi<=100), referring to the sum of the number of the ith group people, and the arriving time STi and departure time Edi(the time format is hh:mm, 0<=hh<24, 0<=mm<60), Given that the arriving time must be earlier than the departure time.

Pay attention that when a group of people arrive at the restaurant as soon as a group of people leaves from the restaurant, then the arriving group can be arranged to take their seats if the seats are enough.
 

Output
For each test case, output the minimum number of chair that TIANKENG needs to prepare.
 

Sample Input
2 2 6 08:00 09:00 5 08:59 09:59 2 6 08:00 09:00 5 09:00 10:00
 

Sample Output
11 6
 想了半天都不知道怎麼寫,思路還是某個巨巨告訴我的,說是一天24小時,開個大數組,然後把題中的小時換算成分鐘,每個時間都對應一個數量,重複的就加起來。最後取最大值
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
int main()
{
	int a[1440+100],b[10100],e[10100];
	int i,n,c,t11,t12,t21,t22,t,d;
	scanf("%d",&t);
	while(t--)
	{
		memset(a,0,sizeof(a));
		scanf("%d",&n);
		for(i=0;i<n;i++)
		{
			scanf("%d %d:%d %d:%d",&c,&t11,&t12,&t21,&t22);
			b[i]=t11*60+t12;
			e[i]=t21*60+t22;
			for(int j=b[i]+1;j<=e[i];j++)
			a[j]+=c;
		}
		
		/*for(i=1;i<1441;i++)
		{	
			for(int j=0;j<n;j++)
			{
			if(i>=b[j]+1&&i<=e[j])
			a[i]+=c[j];
			}
		}*/
		d=0;
		for(i=1;i<1441;i++)
		d=max(d,a[i]);
		printf("%d\n",d);
	}
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章