Surprising Strings

Surprising Strings
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5241   Accepted: 3445

Description

The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its D-pairs are different. A string issurprising if it is D-unique for every possible distance D.

Consider the string ZGBG. Its 0-pairs are ZG, GB, and BG. Since these three pairs are all different, ZGBG is 0-unique. Similarly, the 1-pairs of ZGBG are ZB and GG, and since these two pairs are different, ZGBG is 1-unique. Finally, the only 2-pair of ZGBG is ZG, so ZGBG is 2-unique. Thus ZGBG is surprising. (Note that the fact that ZG is both a 0-pair and a 2-pair of ZGBG is irrelevant, because 0 and 2 are different distances.)

Acknowledgement: This problem is inspired by the "Puzzling Adventures" column in the December 2003 issue of Scientific American.

Input

The input consists of one or more nonempty strings of at most 79 uppercase letters, each string on a line by itself, followed by a line containing only an asterisk that signals the end of the input.

Output

For each string of letters, output whether or not it is surprising using the exact output format shown below.

Sample Input

ZGBG
X
EE
AAB
AABA
AABB
BCBABCC
*

Sample Output

ZGBG is surprising.
X is surprising.
EE is surprising.
AAB is surprising.
AABA is surprising.
AABB is NOT surprising.
BCBABCC is NOT surprising.
/***
    枚舉可過~~~~
    ***/
#include<iostream>
#include<map>
#include<cstdio>
#include<cstring>
#include<string>

using namespace std;

char s[100];

int main()
{
    while(~scanf("%s",s)&&strcmp(s,"*")!=0)
    {
        int len=strlen(s);
        for(int l=1; l<=len-1; l++)
        {
            map<string,int>m;
            for(int i=0; i<=len-1-l; i++)
            {
                char ss[100];
                ss[0]=s[i];
                ss[1]=s[i+l];
                ss[2]='\0';
                string str=ss;
                if(m[str]!=0)
                {
                    printf("%s is NOT surprising.\n",s);
                    goto L;
                }
                else
                    m[str]++;
            }

        }
        printf("%s is surprising.\n",s);
L:
        ;
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章