Paths on a Grid

Paths on a Grid
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 19808   Accepted: 4800

Description

Imagine you are attending your math lesson at school. Once again, you are bored because your teacher tells things that you already mastered years ago (this time he's explaining that (a+b)2=a2+2ab+b2). So you decide to waste your time with drawing modern art instead. 

Fortunately you have a piece of squared paper and you choose a rectangle of size n*m on the paper. Let's call this rectangle together with the lines it contains a grid. Starting at the lower left corner of the grid, you move your pencil to the upper right corner, taking care that it stays on the lines and moves only to the right or up. The result is shown on the left: 

Really a masterpiece, isn't it? Repeating the procedure one more time, you arrive with the picture shown on the right. Now you wonder: how many different works of art can you produce?

Input

The input contains several testcases. Each is specified by two unsigned 32-bit integers n and m, denoting the size of the rectangle. As you can observe, the number of lines of the corresponding grid is one more in each dimension. Input is terminated by n=m=0.

Output

For each test case output on a line the number of different art works that can be generated using the procedure described above. That is, how many paths are there on a grid where each step of the path consists of moving one unit to the right or one unit up? You may safely assume that this number fits into a 32-bit unsigned integer.

Sample Input

5 4
1 1
0 0

Sample Output

126
2

Source

/***
    這是高中的排列組合題目,那時候就會。。。現在,更是很熟悉,想當年啊~~~不扯了...

    m*n的矩形,從左下點走到右上點,有多少種走法,
    走的總路徑一定是m+n,只是有m條邊是橫着的,n條邊是豎着的,即C(m,(m+n))
***/
#include<iostream>
#include<cstdio>

using namespace std;

long long C(long long m, long long n)
{
    if(m > n-m)
        m=n-m;
    long long ans=1,cou=m;
    while(cou --)
    {
        ans*=n--;
        while(ans%m==0&&m>1)
            ans/=m--;
    }
    return ans;
}

int main()
{
    long long a, b;
    while(scanf("%lld%lld", &a, &b) != EOF)
    {
        if(a == 0 && b == 0) break;
        printf("%lld\n", C(a, a + b));
    }
    return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章