POJ 3041 Asteroids(二分匹配)

Description
Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.
Input
* Line 1: Two integers N and K, separated by a single space.
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.
Output
* Line 1: The integer representing the minimum number of times Bessie must shoot.
Sample Input
3 4
1 1
1 3
2 2
3 2
Sample Output
2
Hint
INPUT DETAILS:
The following diagram represents the data, where "X" is an asteroid and "." is empty space:
X.X
.X.
.X.

OUTPUT DETAILS:

Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

題目大意:

在一個網格中有若干個點,每一次可以一下子清除一行或者一列,問多少次可以將網格中的點全部清除

解題思路:

將行做表看作一個集合的點,列座標看作一個集合的點,每個點就連接兩個集合的邊,求出最大匹配就是所要的答案

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include <iostream>
using namespace std;

int map[505][505];
int visit[505];
int match[505],num,n;


int find(int p)
{
    int i;
    for(i=1;i<=n;i++)
    {
        if(map[p][i]==1 && !visit[i])
        {
            visit[i]=1;
            if(!match[i] || find(match[i]))
            {
                match[i]=p;
                return 1;
            }
        }
    }
    return 0;
}




int main()
{
    int i,j,k,m;
    int p,q;
    while(~scanf("%d%d",&n,&m))
    {
        memset(map,0,sizeof(map));
        memset(match,0,sizeof(match));
        for(i=1;i<=m;i++)
        {
                scanf("%d%d",&p,&q);
                map[p][q]=1;
        }
        num=0;
        for(i=1;i<=n;i++)
        {
            memset(visit,0,sizeof(visit));
            if(find(i))
                num++;
        }
     printf("%d\n",num);
    }
    return 0;
} 


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章