HDU 1068

HDU - 1068
Time Limit: 10000MS   Memory Limit: 32768KB   64bit IO Format: %I64d & %I64u

            

Description

the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.
 

Input

Output

Sample Input

7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0
 

Sample Output

5 2
 

Hint

Source

Southeastern Europe 2000

求最大獨立集~

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define maxn 1000
int n;
int linker[maxn],g[maxn][maxn],vis[maxn];
int Find(int x)
{
  for(int i = 0;i < n;i ++)
  {
    if(!vis[i] && g[x][i])
	{
	  vis[i] = 1;
	  if(linker[i] == -1 || Find(linker[i]))
	  {
		 linker[i] = x;
		 return 1;
	  }
    }
  }
  return 0;
}
int main()
{
	char a,b,c;
	int from,m,to,cnt;
	while(scanf("%d", &n) != EOF)
	{
	 cnt = 0;
	 memset(g, 0, sizeof(g));
	 for(int i = 0;i < n;i ++)
	 linker[i] = -1;
	 for(int i = 0;i < n;i ++)
	 {
	  cin>>from>>a>>b>>m>>c;
	  while(m --)
	  {
	   scanf("%d", &to);

	   g[from][to] = 1;
	  }
	 }
	 for(int i = 0;i < n;i ++)
	 {
	   memset(vis, 0, sizeof(vis));
	   if(Find(i))
		 cnt ++;
	 }
	 printf("%d\n", n - cnt/2);
	}
	return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章