【威爾遜定理】HDOJ YAPTCHA 2973

YAPTCHA

                                           Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                   Total Submission(s): 756    Accepted Submission(s): 396



Problem Description
The math department has been having problems lately. Due to immense amount of unsolicited automated programs which were crawling across their pages, they decided to put Yet-Another-Public-Turing-Test-to-Tell-Computers-and-Humans-Apart on their webpages. In short, to get access to their scientific papers, one have to prove yourself eligible and worthy, i.e. solve a mathematic riddle.


However, the test turned out difficult for some math PhD students and even for some professors. Therefore, the math department wants to write a helper program which solves this task (it is not irrational, as they are going to make money on selling the program).

The task that is presented to anyone visiting the start page of the math department is as follows: given a natural n, compute

where [x] denotes the largest integer not greater than x.
 

Input
The first line contains the number of queries t (t <= 10^6). Each query consist of one natural number n (1 <= n <= 10^6).
 

Output
For each n given in the input output the value of Sn.
 

Sample Input
13 1 2 3 4 5 6 7 8 9 10 100 1000 10000
 

Sample Output
0 1 1 2 2 2 2 3 3 4 28 207 1609
 

Source

題意:

計算題目中給的式子。

解題思路:

當3k+7不是素數時,可以得到((3k+6)!+1)/(3k+7)=[(3k+6)!/(3k+7)],此時括號內的值爲0.

當3k+7是素數時,由威爾遜定理知(3k+6)! = -1 (mod 3k+7) ,可以得到((3k+6)!+1)/(3k+7)=[(3k+6)!/(3k+7)]+1,此時括號內的值爲1.

AC代碼:

#include <stdio.h>
#include <math.h>
#include <algorithm>

using namespace std;

const int MAXN = 3100000+10;

int prime[MAXN];
int E[1000010];

bool is_prime()
{
    prime[0]=prime[1]=false;
    for(int i=2;i<MAXN;i++){
        if(!prime[i]){
            for(int j=i*2;j<MAXN;j+=i){
                prime[j]=true;
            }
        }
    }
}

int init()
{
    is_prime();
    E[1]=0;
    int res=0;
    for(int i=2;i<=1000000;i++){
        if(!prime[3*i+7]) E[i]=E[i-1]+1;
        else E[i]=E[i-1];
    }
}


int main()
{
    int t;
    init();
    scanf("%d",&t);
    while(t--){
        int n;
        scanf("%d",&n);
        printf("%d\n",E[n]);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章