【威爾遜定理】HDOJ Zball in Tina Town 5391




Zball in Tina Town

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 1356    Accepted Submission(s): 705


Problem Description
Tina Town is a friendly place. People there care about each other.

Tina has a ball called zball. Zball is magic. It grows larger every day. On the first day, it becomes 1 time as large as its original size. On the second day,it will become2 times as large as the size on the first day. On the n-th day,it will become n times as large as the size on the (n-1)-th day. Tina want to know its size on the (n-1)-th day modulo n.
 

Input
The first line of input contains an integer T, representing the number of cases.

The following T lines, each line contains an integer n, according to the description.
T105,2n109
 

Output
For each test case, output an integer representing the answer.
 

Sample Input
2 3 10
 

Sample Output
2 0
 

Source
 


題意:

計算(n-1)! mod  n  的值

解題思路:

威爾遜定理:p是素數 則( p -1 )! ≡ -1 ( mod p )

p不是素數  結果是0. 注意4的情況!

AC代碼:

#include <stdio.h>
#include <math.h>
#include <algorithm>

using namespace std;

bool is_prime(int n)
{
    if(n==1||n==2) return true;
    if(!(n&1)) return false;
    int m=sqrt(n);
    for(int i=2;i<=m;i++){
        if(n%i==0) return false;
    }
    return true;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
        int n;
        scanf("%d",&n);
        if(n==4){
            printf("2\n");
            continue;
        }
        if(is_prime(n)) printf("%d\n",n-1);
        else printf("0\n");
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章