【線段樹-區間求最值】HDOJ Billboard 2795



Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16333    Accepted Submission(s): 6921


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
3 5 5 2 4 3 3 3
 

Sample Output
1 2 1 3 -1
 

Author
hhanger@zju
 

Source
 


題意:

給一個h*w,的木板,在上面貼x*w的廣告單,從左往右,從上往下一直貼,就是儘量往上貼,往左貼。求第n個廣告的位置。

解題思路:

利用線段樹求解,存放的是還能放多長的廣告單。利用區間最值,可以求解此類問題。

query區間求最值問題。

需要注意到當h>n時,h的值是無意義的,所以,h最大就是n。

AC代碼:

#include <stdio.h>
#include <string.h>
#include <algorithm>
#define Lson L,Mid,Rt<<1
#define Rson Mid+1,R,Rt<<1|1

using namespace std;

const int MAXN = 200010;

int sum[MAXN<<2];
int h,w,n;

void PushUp(int Rt)
{
    sum[Rt]=max(sum[Rt<<1],sum[Rt<<1|1]);
}

void build(int L,int R,int Rt)
{
    sum[Rt]=w;
    if(L==R) return;
    int Mid=(L+R)>>1;
    build(Lson);
    build(Rson);
}

int query(int x,int L,int R,int Rt)
{
    if(L==R){
        sum[Rt]-=x;
        return L;
    }
    int Mid=(L+R)>>1;
    int res=(sum[Rt<<1]>=x)?query(x,Lson):query(x,Rson);
    PushUp(Rt);
    return res;
}

int main()
{
    while(scanf("%d%d%d",&h,&w,&n)!=EOF){
        if(h>n){
            h=n;
        }
        build(1,h,1);
        while(n--){
            int x;
            scanf("%d",&x);
            if(sum[1]<x) printf("-1\n");//如果最大值小於x,就是放不下了。
            else printf("%d\n",query(x,1,h,1));
        }
    }
    return 0;
}


Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16333    Accepted Submission(s): 6921


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
3 5 5 2 4 3 3 3
 

Sample Output
1 2 1 3 -1
 

Author
hhanger@zju
 

Source
 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章